IP Passthrough-RGMII not working on RM502Q-AE

I successfully configured the RM502Q-AE to use “COMMON-RGMII” Ethernet mode via the command AT+QETH=“rgmii”,“ENABLE”,1,0. However when attempting to change over to “IP Passthrough-RGMII” Ethernet mode, have set the IP Passthrough-RGMII MAC address (AT+QETH=“ipptmac”,XX:XX:XX:XX:XX:) but when I then execute the command AT+QETH=“rgmii”,“ENABLE”,1,1 it returns with “ERROR.” I have tried completely disabling RGMII, changed data interface back to USB, and disabled the Ethernet driver and power cycled the modem but still when trying to issue the command to enable IPPT RGMII mode, it returns “ERROR”.

Given this, I am wondering if IPPT mode of RGMII is either broken or there is some order of operations here which is not clear in the documentation. I have reached out to my FAE already and he was unclear on this as well so hopefully Quectel can provide some feedback/guidance on whether IPPT is supposed to be functional and if so, the order of steps to enable it. If it helps I am running the R13 firmware but can test on R11 versions as well if there is some configuration difference in the latter which might be the cause of the issue.

Thank you!

Dear @hazarjast
Sorry for the late, did you solve the issue now?

I am having problems getting RM520n-gl to get IP passthough working. I am tried AT+QETH=“rgmii”,“ENABLE”,1,1 and get error and also at+qmap=“mpdn_rule”,0,1,0,1,1"FF:FF:FF:FF:FF:FF" and get error. Is there something i need to disable first to get these command to work?

Update i did find a typo in my command at+qmap=“mpdn_rule”,0,1,0,1,1"FF:FF:FF:FF:FF:FF" should be at+qmap=“mpdn_rule”,0,1,0,1,1,“FF:FF:FF:FF:FF:FF”
Now when I show the rule
[2023-06-10_17:19:08:603]+QMAP: “MPDN_rule”,0,1,0,1,1
but is still not working when show mpdn_status it shows its still in nat mode
[2023-06-10_17:19:00:488]+QMAP: “MPDN_status”,0,1,0,0
[2023-06-10_17:19:00:488]+QMAP: “MPDN_status”,1,0,0,0
[2023-06-10_17:19:00:488]+QMAP: “MPDN_status”,2,0,0,0
[2023-06-10_17:19:00:488]+QMAP: “MPDN_status”,3,0,0,0
and i am still receiving to my network card instead fo the 10.x.x.x from at&t that is on the wan of the modem. I am unsure where to go from here.