IP Passthrough-RGMII not working on RM502Q-AE

Hello,
I successfully configured the RM502Q-AE to use “COMMON-RGMII” Ethernet mode via the command AT+QETH=“rgmii”,“ENABLE”,1,0. However when attempting to change over to “IP Passthrough-RGMII” Ethernet mode, have set the IP Passthrough-RGMII MAC address (AT+QETH=“ipptmac”,XX:XX:XX:XX:XX:) but when I then execute the command AT+QETH=“rgmii”,“ENABLE”,1,1 it returns with “ERROR.” I have tried completely disabling RGMII, changed data interface back to USB, and disabled the Ethernet driver and power cycled the modem but still when trying to issue the command to enable IPPT RGMII mode, it returns “ERROR”.

Given this, I am wondering if IPPT mode of RGMII is either broken or there is some order of operations here which is not clear in the documentation. I have reached out to my FAE already and he was unclear on this as well so hopefully Quectel can provide some feedback/guidance on whether IPPT is supposed to be functional and if so, the order of steps to enable it. If it helps I am running the R13 firmware but can test on R11 versions as well if there is some configuration difference in the latter which might be the cause of the issue.

Thank you!

Wow, I see this got a lot of attention, lol. /s

For anyone who cares, I re-flashed the same R13 firmware I was on to get back to square one and now enabling RGMII in IPPT mode works without returning “ERROR” as it was before.

After thinking about it more I think the issue may have had to do with RGMII status still showing an active data call on the default APN even when it was supposedly disabled. For others wanting to go from RGMII COMMON to IPPT, removing the SIM or something like ‘AT+CFUN=0’ might be needed to clear the data call and get RGMII back to a disabled state (status of “-1”) prior to trying to enabling IPPT mode. If that doesn’t work then I’m going to guess getting stuck in COMMON might be a bug.