Installing 5g Gobinet and QMI WWAN driver on nvidia jetson agx xavier


I am working on a project where i need to install Gobinet and QMI WWAN drivers on nvidia jetson AGX xavier.

I followed the steps from Quectel_LTE5G_Linux_USB_Driver_User_Guide_V2.0.pdf.

  1. I was able to modify kernel configuration and load the jetson with new Image. (performed all the steps from
    3.2 to 3.4 in the quectel user guide).
  2. After flashing the jetson with modified image, when I ran lsusb command, it displayed below
    Bus 002 Device 002: ID 2c7c:0800

As I am new to this filed, when I tried to follow next steps from the guide that is ‘4 - Test the Module’, I could not follow the steps. What exactly busybox is doing? how do I proceed next to make drivers work?

I followed the steps from user guide and when i tried sudo ./quectel-CM -s I am getting below error.

Any idea why am I facing this issue?

hello, you need to use a newer version of the tool, and you need to install qmi driver.

Can you please provide steps on how to install quectel driver?

After cross-compilation, use the insmod command to load.

I have downloaded the recent version of quectel-cm. That is Quectel_QConnectManager_Linux_V1.6.0.24.
Still i am getting the below error.

can you share the documentation that including these steps?
what is the procedure if we are compiling natively on the jetson without cross compiler?

any help would be really appreciated. Thank you

Ok, I will send a user guide to you via email, you can refer to it.

Hello @Isaac.Wang-Q could you please also send those files to me? I am trying to add the RM500Q module to AGX Xavier. Also, I would like to know if there are instructions for that board?


Hello @Isaac.Wang-Q could you also send me these files? I’ve also started working with the RM500Q module and want to add it to the Jetson Nano.
Thank you in advance!

@luongtommy @marcoandrade Ok, I will send a user guide to you via email, you can refer to it.

Thank you very much for the guide!
I’m still figuring out which drivers I should install for Ubuntu 18.04, can you help me and send the correct drivers right away? Thank you in advance

check the kernel version use uname -r , install the driver version closest to the kernel version.

Hello @Isaac.Wang-Q could you please also send those files to me?I am trying to get the RM500Q to run on a Jetson Xavier NX.


Hello @Isaac.Wang-Q. We are also trying to get the RM500Q-AE to run with an Nvidia Jetson Nano running Ubuntu 18.04.6 LTS on a Kernel version 4.9.253-tegra.
@luongtommy, did you have any success with the Jetson Nano on your side?

Hi @Isaac.Wang-Q , we are on the same path to RM500Q-AE used on NVida Jetson Nano an Xavier NX running latest Jetpack 4.6.1.

Could you please mail the user quide to me as well?

Ok, I will send it to you via email, please check it.

Hi @Christoph_Uran ,@Hacky, I successfully run RM500Q on NVida Jetson Xavier NX with latest Jetpack 4.6.1 . but it only works with usb2.0. The usb3.1 interface will always report “can’t set config #1, error -32” and cannot enumerate ttyUSBx.

@user5.wm maybe you could update the firmware version to fix usb3.1 enumeration problem.

@Isaac.Wang-Q ,Sorry for the late reply. Is there any firmware that supports usb3.1 interface?

@Isaac.Wang-Q I have just obtained the latest version of firmware from my FAE. I will upgrade and test it later. Anyway, thank you for your reply