IMSI attach working only in 3G


with one of our customers, our modems are having problems attaching to the Packet Domain service. An APN with username and password is configured.

  • If all network standars are allowed (at+qcfg=“nwscanmode”,0), the modem tries to attach to the 4G network, and the client reports that on their RADIUS server they see failed login attempts, with user = IMSI and no password provided. Sometimes (after, say, 10 or 20 minutes of trying), the modem then seems to perform an attach using 3G and then immediately perform an upgrade to 4G.
  • When I disable PS (at+cgatt=0), the modem connects to a 3G network. When I then enable PS (at+cgatt=1) again, the modem is not able to connect (at+cops shows “+COPS: 0”, and at+qnwinfo reports “No Service”).
  • If the modem is forced to 3G only (at+qcfg=“nwscanmode”,2), network attachment and IP connection succeed without problems.
  • Also, when performing a manual connect to a 4G network (AT+COPS=4,2,,7), the modem connects without problems.

The modem is an EG91, Revision EG91EXGAR10A03M1G.

Our client tells us that this problem only happens with our modems, and some TP-Link modems.

Can you give mi any hints to why this might be happening, and how to solve the issue?


Hi tmayr,
It can not give a well solution according to your description. If the IMSI adapt 3G only, you can not force the module register 4G, please check the signal of the test point or you can update the latest version and retry. Before that you need cancel the manual link to network(AT+COPS=0), thank you.


what do you mean by “If the IMSI adapt 3G only”?
Signal seems to be fine, as I said, I am able to upgrade to the 4G network after connecting in 3G, the modem just refuses to connect to 4G automatically.
I am following the official PPP Application Notes for my modem.


To clarify: the radius log first reports a lot of failed EUTRAN connection attempts. Then suddenly a successful UTRAN connection appears, and five seconds later the session is upgraded to EUTRAN.
I’m not sure anymore if the manual connection (AT+COPS=4,2,…,7) always works, or if that was just luck.

The client also reports that they had the same problem with other modems, and were able to solve this by using the following (undocumented) commands:

  • AT+CEVDP=4

I tried these commands, but while CEMODE was already equal to 2, the AT+CEVDP command is not recognized at all.
Basically I think we should completely disable Voice and SMS (as we don’t need them), but I couldn’t find the commands to do so.