I am trying to do httppost using AT+QHTTPPOST command, but every time when I send it returns me “+CME ERROR: http dns error”.
I referred the following link as well:

before this I tried the example from the document (GSM_HTTP_AT_Commands_Manual_V1.1.pdf) as well…

but again same result.

Can anybody tell me what am I doing wrong?
Any help will be appreciated.

Dear Iunknown,
Thanks for your inquiry in Quectel forum.
About your quetsion, could you help to double check whether your URL is normal or not ? Or whether you use the HTTPS not HTTP URL ? The following is the AT sequence of HTTP for your reference, please double chek it.

And if you use the customize HTTP header, you can refer to the following example. Thanks!

Hi Kyson,

Thanks for your reply.
I tried the exact steps as you mentioned above.
Initially it worked (not completely)…it didn’t worked completely is because,it at least got connected after AT+QHTTPPOST,but after posting the data it replied me http response failed.

But now again it is failing with the same response saying http dns error.

So can you please tell me whats wrong I’m doing ?because it got connected initially.

Dear Iunknown,
Just as i have said to you, please double check whether the URL you used is normal or not, you can try to open it with a browser. Or you can change another URL to have a try again. Thanks!