How to use FTP with BG770A-GL

Hello together, i have a question about the FTP function with BG770A-GL.
As you can see in my log file everthing is fine with the LTE-M connection and i can also log in to the Server.
Requesting the size of the file on server works also.

Now the problem. All other AT+Commands end up with an Error. Why?
Finding the file doesn´t work: AT+QFTPPWD → Answer: 627,500
Downloading to UFS doesn´t work: AT+QFTPGET → Answer: 627,500

Do i have to open / configure another PDP context?
I have done this but there was still the same issue.

Thanks for your help.

I also tried it with FTP(S) today, but its the same old story…

Has anyone an idea?

Hi @MPEngineering

Sorry for the late response, which FW version are you using now?


we are using BG770AGLAAR01A05_01.200.01.200.

Hi @MPEngineering

for quickly debug this issue, if possible to share you server infos for us? then we can test my side and debuging?

Sure. I´ll send you a private message.

Thanks for helping.

Hi @MPEngineering

Seems i cannot access you server, probably limited by network. so i test with my local server and it works good on 01.202 version, could you please help update to this version then try again?


[2023-12-20_18:53:20:722]+QFTPCFG: "contextid",1





[2023-12-20_18:53:22:584]+QFTPCFG: "ssltype",0


[2023-12-20_18:53:23:485]+QFTPCFG: "sslctxid",0




[2023-12-20_18:53:28:428]+QFTPOPEN: 0,0

[2023-12-20_18:55:46:414]+QFTPCWD: 0,0

[2023-12-20_18:55:55:900]drwxrwxrwx   1 user     group           0 Sep 25  2021 .
[2023-12-20_18:55:55:916]drwxrwxrwx   1 user     group           0 Sep 25  2021 ..
[2023-12-20_18:55:55:916]-rw-rw-rw-   1 user     group          65 Sep 25  2021 1.txt


[2023-12-20_18:55:55:916]+QFTPLIST: 0,179


[2023-12-20_18:56:19:473]+QFTPGET: 0,65