How to run internet on EC25 module

hi team,
we connected EC25 module to minnowboard. we are using yocto project.

  1. SIM card is detecting but interface is not creating for sim card .
  2. where to do settings (eg. APN settings ,…) or which AT command need to fire to run internet in EC25 module ?
    please help

Dear Sir,
Thanks for your inquiry in Quectel forum.
Please share more information with us about your issues.

  1. what do you mean about interface not creating for sim card? what is the interface ? what do you want to do?
    2.As far as i know that yocto is also a kind of Linux system, it also need to install the USB driver and use PPP or gobinet or WWAN to dial up, then access the internet. Please check the following document. Thanks!
    Quectel_WCDMA&LTE_Linux_USB_Driver_User_Guide_V1.8.pdf (1.1 MB)

I followed same document that u mentioned.
For these module voice call and message is happening but i am not getting how to connect
The ppp0 interface is not created (ifconfig command) after running pppd call quectel-ppp script.

steps i did :-

  1. install ppp package in linux (with build image)
  2. created 3 scripts as per document (quectel-ppp, quectel-chat-connect , quectel-chat-disconnect )
    3) after that i run @ pppd call quectel-ppp script then logs also not came.

I attached screenshot.
please help.

Dear Sir,
Please click the following link to download the needed ppp scripts. And follow up the following steps to modify your setting. Thanks!

Hi ,

thanks for your quick responce, Everything (logs) is coming as per documnet.
but interface is not created (ppp0),
ip-up is already there, need to copy ur ip-up file ?
the /etc/ppp/resolve.conf is empty.
i am shearing screenshots.

it stuck here , then i manuallty terminate(ctrl+c) these.

my ip-up file

Dear Sir,
Just as you have said that if you do not add & when you dial up, you can open another terminal to check whether you have dial up successful with ifconfig.
And if you already add &, you can send with enter when the ppp stop, cannot send ctrl+c. Because CTRL+C is to stop PPP dial up. Thanks!

i run these command background and then i used ifconfig ; now its working ,
thanku very much sir for ur help.

Ok, got it. Thanks for your updating. You can go on your test. Thanks!

hi ,

  1. how to write chat script (with explanation ) with different simcards ?
    is there any documents to explain all these then please share me .

Dear Sir,
About the script, you can modify it by yourself. We have no such document. You can search on internet, there have many information about how to modify script. Thanks!

i am using EC25 module EVB , In that EVB COM1 main port is there what is
the actual use of COM1 main port ? they given it is for AT command communication , but we can send AT command through usb micro cable (power cable) also .

Dear Sir,
Yes, correct. The COM1(MAIN) in the EVB is connect to module’s UART port. It also can send AT command. Thanks!

we are getting internet access , but how to do fallback function (means LTE will come to 3g or 2g after getting that particular range and again LTE module shold go 4G if we get 4g range) ?

module - EC25_E

Dear Sir,
Glad to hear that you already can get internet access. About fallback function, if the outside network changed, it will changed automatically. If you want to test it, you may have such test environment. Normally, this test just happened on lab environment.Thanks!

when module is on condition and that time only when we remove a sim card and again insert it , then that time sim card wont be detect . then how to do it possible ?

Dear Sir,
Just as you have said that you may need SIM card hot-plug function. If you want to use such function,please make sure your hardware design of SIM card have connect the SIM_Presence PIN, and use AT+QSIMDET command to enable it. Thanks!

ok. thanx i will try out here

Hi sir ,
when i am running command - “pppd call quectel-ppp” , after that i am getting interface “ppp0” ,
the issue is the dns adresses is not reflecting in /etc/resolv.conf. thats why we are not able to ping google.
after manually adding dns adresses in resolv.conf we can access internet ,
how it will automatically refelect over there ?

module - EC25_E

Dear Sir,
Normally, the standard Linux 's ip-up will set DNS, do not need to set it manually. For your issue, it is better to check whether it is the system issue. And you just need to set it one time, do not set again, even you have reboot your machine. Thanks!

Hi ,
For enabling gpsOneXTRA assistant function . we need to download xtra.bin or xtra2.bin these 2 files from but not able to download files. can u send u these files.

After downloading how to add in LTE modem ? because these files wiil be in local PC.
please send Quectel_QCOM_User_Guide.pdf .

module -EC25-E