How to insert the files to calibrate GNSS function on EP06-E

Hello Everyone,

It is quite unclear to how to insert these files provided by Quectel documentation.
I’ve read the documentation several times, tried the commands, and every time I was unsuccessful with the device just report me error messages…
Should be adding these internet addresses, or the file downloaded from these addresses?

Would be nice if Quectel can give examples on several situations that the developers and customers can face when they update or develop. (for example, offline files, or insert the addresses on the AT Commands…)

The addresses of the gpsOneXtra Assistance:

So, how can Quectel moderators, and the support team, (@Puck-Q @herbert.pan-Q and many other talented from the Quectel) can help me with my issue?

I’m not asking just for me, but others here faced the same (or similar) issue.
I humbly beg and ask for this help, and I take the opportunity to thank you all in beforehand.

Kind Regards,

Dear Mr. Marlon Forsgren,

There is an example for XTRA in doc Quectel_LTE-A(Q)_Series_GNSS_Application_Note_V1.1, do you have this version? Please refer to chap 3.3 for the detail. If any question, please feel free to let me know.

Dear Marlon Forsgren,

  1. Firstly copy the URL you listed above in the internet browser and then download the XTRA file(for example xtra2.bin) to your computer.

  2. Use FILE command upload the XTRA file to module UFS
    For example:
    AT+QFUPL=“UFS:xtra2.bin”,60897,100 //AT+QFUPL=,<file_size>,

    //Upload xtra2.bin from PC to module, we can use QCOM tool
    +QFUPL: 60897,XXX //+QFUPL: <upload_size>,

  3. After XTRA file uploaded to module, then refer to GNSS document. I have tried the commands that have on the manual and have several errors.
QCOM have one function “send file” can I use it?
Kind Regards

Hi Marlon Forsgren,
Please check below screen shot of QCOM tool.

Dear Marlon Forsgren,
For EP06 XTRA URL, please use followings:

1 Like




The file name is incorrect. Should be “UFS:xtra2.bin”
As for myself, I just found out that the xtra files are updated constantly. When I downloaded the latest file, it worked. Just FYI, the time is in UTC (yup, I made that mistake by entering my own timezone).

1 Like