Help me with this

you even could not see the 2C7C. It means that there is something wrong with Hardware.
And I don’t know how you send AT.

that was before, like yesterday i tried sending an SMS and it worked just fine but when I try make a call it doesnt go through. I managed to use the data of my sim card on the module , and I managed to send an sms and it worked. Only calling it keeps saying no carrier.

Please help I think we are almost there

Also is it possible we chat as I work so i can show you the results , as i need it to be done asap as its my project. Im running out of time.

Make sure that you can see the Quectel device in

lsusb -t

I know you want to set up data internet connection.
Please make sure the USB device is recognized.

it is recognized by the two commands

Please check this one out

It seems that the usb interface is recognized.

dmesg | grep cdc_ether
dmesg | grep usb0

Please check.

sorry for the delay

As the photo shows, there is usb0

Please check

ifconfig usb0

route -n

check this it shows its connected

this image is also showing that my APN is connected but there is two things that I want help with ,

I want help with using my sim card data on my raspberry pi instead of the wifi of raspberry pi.

the second thing that I want which is more important than connecting to the internet that is calling I need your help to make the call from the module.

can you please send me the latest firmware for this module RM502Q-AE and you can check if my module is updated to the lastest version from this image because i think its not the latest firmware

Command: AT+CGMR

There is usb0 and it already got an IP.
The route table is not correct.
Please try

route add default dev usb0 gw

Regarding using data I figured it out my issue is on how to make call using the module it doesn’t work.