Help me Quectel M26 send sms

Why when I use AT + CMGS command, the content of the message is 123 but when the recipient receives another message with characters or Chinese, I don’t understand why?

please Select TE Character Set to GSM using below command.
Also help to share the AT logs.

I tried AT + CMGS = “GSM” but it still is

please find the below snap.

might be your handset setting not supporting text from Modem.
please try to send the text message on the other mobile handset.

I try it on another device and it’s totally normal that only m26 is affected

Try setting the text-mode parameters explicitly first with:


Validity period is set there to 173 (7 days). Let me know if you want another value.