Help downloading Android Source Code

Hi there, i need some help downloading android source code, i have Ubuntu 20.04 set up in my machine, and i remember this working the first time, but for some reason the repo init command i am using is giving me some problems.

The command iam using is this;

repo init -u https://source.codeaurora.org/quic/la/platform/manifest.git -b release -m LA.UM.7.6.2.r1-09500-89xx.0.xml --repo-url=git://codeaurora.org/tools/repo.git --repo-branch=caf-stable
Blockquote

The error i get is the following.

cmd: [β€˜git’, β€˜tag’, β€˜-v’, β€˜v1.12.16’]
stdout:

object 666d534636d262cbfd971509dd0f0be0cddb2e11
type commit
tag v1.12.16
tagger Conley Owens cco3@android.com 1398976458 -0700

repo 1.12.16
stderr:

gpg: Signature made Thu 01 May 2014 01:34:18 PM PDT
gpg: using RSA key 67B7E448692B382C
gpg: Can’t check signature: No public key
fatal: cloning the git-repo repository failed, will remove β€˜.repo/repo’

I really need help solving this issue, any tips or help will be greatly appreciated.

Thanks,
Walter

Hi, have you tried more times? and pls try Ubuntu 16.04, it is what we recommend.

Thanks,

Hi, yes i have tried multiple times without any luck, I will try Ubuntu 16.04.

Walter

Hi, walterf

Ok, thanks

Hi again, so I installed Ubuntu 16.04 and I seem to be able to start repo sync but I keep getting the following error:
Fetching projects: 34% (234/686) Fetching project platform/vendor/google_easel
fatal: repository β€˜https://source.codeaurora.org/quic/la/platform/vendor/google_easel/’ not found
fatal: repository β€˜https://source.codeaurora.org/quic/la/platform/vendor/google_easel/’ not found
error: Cannot fetch platform/vendor/google_easel

I have already tried many times and it fails at the same point, can you please help me with this?

Thanks,
Walter

Hi, Walterf

let me check

1 Like

Hi,

I am experiencing the same issue. I think the repository /vendor/google_easel/ is not available anymore.
Do you know where it has been moved to?

you could ignore it ,it will not influence on your compile