Gnss ec200u select only gprmc

HI ,Quicktel Team,I am using EC200U for GNSS purpose ,with UART as outport ,i am unable to select only GPRMC as my receiving data ,the command i used was “AT+QGPSCFG="gnssnmeatype",2\r” the reply is OK but even after rebooting there is no changes I’m getting all the data from other satellites .I would be grateful if you could solve my issue .Is there another AT commands I need to send before this ??.
Thank you and regards ,

Hi @Ujwal_Kumar_N_L_EC
AT+QGPSCFG=“gnssnmeatype”,2 command takes effect after restart. Did you power off and restart after setting?