g_InitCmds AT+CFUN

Hi, here’s a question, why if I add “AT+CFUN=0” to g_InitCmds[], I don’t come back from calling Ql_RIL_Initialize()? I just freeze in it.

const char* g_InitCmds[] = {
“AT+CREG=1\r”, .

AT+CFUN=0 I need it so that when the module starts, it is initially in the minimum functionality.

Could you tell me module’s version?(Please use ATI to check)

Hi, Winnie.
Sorry, I forgot to mention, I use the MC60 module.
Version: MC60CAR01A12

Hi Sad:
Your issue needs to be solved by other colleagues.
Please help to deal with this issue.Thank you in advance.

Dear Sad:

“AT+CFUN=0” will cause the module to turn off the power in the RF part.Will disconnect the entire network and connection of your module.

If you want to use the low-power feature, you need to refer to the file “example_rtc.c” for examples of enabling and disabling sleep.Please refer to it.Thank you.

Hi Grey,
Thanks for the reply.
I need the module to be in low functionality at startup.

The module starts up, the condition is checked, if the condition is correct, I enable the full functionality of the module(AT+CFUN=1), if the condition is not correct, I just go to sleep.

So I am wondering why I can’t switch the module to AT+CFUN=0 during initialization?

Dear Sad:

To use the AT directive in OPEN mode, you need to run the function “Ql_RIL_Initialize()” first. What is the logic of your code?

Hi Grey,

As I wrote above, I need to minimize the power consumption of the module at startup. My logic is to start the module with minimal functionality and to keep it in that functionality until a certain event. My question is, is it possible to use AT+CFUN=0 in g_InitCmds[] for Ql_RIL_Initialize()?

Dear Sad:

Open can only be initialized by calling “Ql_RIL_Initialize()” before sending an AT directive.