FTP Get to download large files

Hi, I want to download a file using FTP protocol based on EC2x&EG9x&EG2x-G&EM05 Series FTP(S) Application Note. Now, I can configure and then connect successfully to my FTP server.
with the command:

If my desired file size is less than 60MB, it will be downloaded successfully. because probably the EC25-e module UFS storage size is approximately 60 MB.

Actually, my desired file size is over 2 GB, and when i run the command below:
I get this response:
+QFTPGET: 613,0
that based on documentation, it is interpreted as below:
+QFTPGET: File error,0

I think because my UFS storage gets full, it throws this error, do you have any idea about how to manage automatically storage space? or are there other alternatives? like storing the desired file in other storage? (I connected the ec25-e module to bananapi m2ultra with Armbian OS on 32GB of SD card.)

Hi @mehdi_parastar
Yes, this seems to be an error caused by insufficient UFS space. Have you tried downloading the file directly to the SD card? AT+QFTPGET=“myfile.iso”,“SD:myfile.iso”

Thanks, the result is like:


+QFTPGET: 613,0       // File error

and also I have this:

+CME ERROR: 419     //  Fail to get disk info