Firmware RM520NGLAAR01A08M4G Release Notes

Where can I get the release notes for the latest Firmware RM520NGLAAR01A08M4G, thank you

Dear @logi
I have sent it to you via Message, please check.

Hi @silvia ,

I’m interested in the release notes for that version, too.

Thanks in advance.

Dear @nschemel
I have sent it to you via Message, please check.

Hi @silvia
Do you know the syntax for the sim recovery command? There’s 3 variables it appears when I query the current status of the command with AT+QSIMCFG=“sim_recovery” on the RM520

Also, I think there might be an issue with the current firmware. (A08) While in RGMII mode and IPPT enabled with IPPT NAT also enabled, sometimes the connection completely goes out. Even to the point where nothing on VLAN0 can be reached ( I suspect it has do with the providers IP address changing or switching cell sites/towers? I tried 2 different providers. On T-Mobile it is most noticeable, as switching between NSA and SA always changes the IP. While on AT&T it stays up longer but eventually the same thing happens. There are times when the IP changes and the ethernet port shuts off and comes back up with the new IP as it should but not every time. The issue is made even worse when moving around (driving around with it). This was tested by driving on interstate where each carrier’s signal defiantly exists, confirmed by keeping an eye on signal info on my phone as well. The issue is solved temporarily by rebooting the RM520 but it eventually happens again and needs rebooted again.

I figured I would ask about this here first before I reach out to Ketn Wang.


Please send the firmware and release note to me as well when possible.

Dear @iamromulan
Actually, only from the description, it is hard to locate this problem.

Dear @joeym82956
I have sent it to you via Message, RN in the firmware package, please check.

I can try to retrieve journald log data via ADB if that would be helpful?

I just saw once the same issue you explained on my RM520EU version on Ooredoo Kuwait network. It was more observed when I was using Nokia FM3.1 and Netgear M5.
Issue is here there is no SA and NSA switching, as the operator always use NSA.
The only remedy as you said is to reboot the module.