Failed AT+QHTTPPOST when using HTTPS on AWS server

Hi all,

I am using the BG96 module to send measurements to an HTTPS server ( However, it fails with a +CME ERROR: 701. I find it very hard to debug the problem, since i can’t get much information out of the BG96 regarding the error. It works on other https servers using the same method. I have tried using different cipher suites (0xC02F, 0x0005, 0xC027).

  • Which seclevel do I have to use? (Have tried all three…)
  • Do I need to store specific certificates on the BG96? I tried generating my own through openssl and uploading them and also using the server’s CA Certificate.
  • Is there any better way to get error information other than just reading the response codes?

Any help is much appreciated!


  • Amazon IoT Core Menu - Manage
  • Create Thing and Certificates, Download certificates and Activate it
  • Policies: Allow
  • Interact - get HTTPS URL for host name

Thank you WizIO, but unfortunately I am using InfluxDB Cloud 2.0, which does not let me create things and certificates as if I’d use AWS IoT Core directly.

I dont know other way

This problem was caused by our server not having the ciphers that the BG96 wanted. Although our server had one cipher that was supposed to be available on the BG96, obviously it wasn’t working, and we would always get 701 whenever we tried to post or get from from our server using https. If you are getting this problem from a server you do not control, then I fear you are out of luck.

To solve the problem, we increased the ciphers on our server to the following: