"FAIL, DL_Firehose error!" Using QDLoader to port to flash onto bricked BG95-M3

After shorting VDD_ext and USB_BOOT on a bricked BG95-M3, I’m trying to perform a forced download. I’m running QFlash_V4.19 as an admin, and am trying to flash from the [Tool_For_BG95M3_M5_600L_Erase_EFS2APPS_20200408] folder that was provided to me on these forums.

I keep receiving the error message “FAIL, DL_Firehose error!” Any suggestions?

To add: I’m trying to flash over the ‘QDLoader 9008’ port w/ Baudrate 460800. I’ve also tried 115200.

It is a tool compatibility problem. Only a few customers will encounter this problem. Please try the latest qflash version or Qualcomm original tools QFIL ( you can download it from qualcomm website)


Thanks for the response @Stephen.Li-Q but unfortunately I’m still encountering the same issue using QFlash V_5.3. I’m trying to use QFIL but am having issues with that as well so please let me know if you have other recommendations.

So I’ve circled back around to this project and am again trying to unbrick a BG95-M3. I seem to have gotten the module into force download mode, as I can see the QDLoader COM port in device manager, but when I try to use QFlash V5.3 to flash new firmware onto the board I keep getting the error message from before. Has anyone had this problem and resolved it?

I don’t understand why these tools would be incompatible? I’ve tried this process on 3 different bricked modules and am getting the same results.

@Stephen.Li-Q Do you have any other recommendations? A different version of [Tool_For_BG95M3_M5_600L_Erase…] to try maybe? I’ve tried every troubleshooting recommendation I could find on the forums and elsewhere pertaining to the use of QFlash and QFIL to solve my problem. The latest incidence of a device becoming bricked was after flashing the example_gps app that came with the QuecOpen SDK onto a BG95-M3, so I imagine I’m going to need to be able to unbrick more of these devices in the future.

This was resolved by using QFlash_V4.19 and a 921600 Baudrate

I too am seeing this problem with the BG95 M3… I am using Qflash V4.12 I have requested a newer version but will have to see if I get a reply to my request. I am attempting a firmware update and just getting the error:
Not sure what this is all about I tried this 921600 baud rate but no luck for me

Also the link above to an updated version of Qflash is no longer functional

Is your module bricked?

My module was bricked and I was in Bootloader (Forced Download) mode when the solution I described worked. Aside from using QFlash, the solution I described doesn’t really apply to standard FW updates.

1 Like

I see, no I have not put this into forced download mode. Not sure how to do this… But did you find that 921600 baud rate was the only one that worked? I am just surprised we are not using 115200 here

I may put in a ticket for this one

I downloaded version 5.5 of Qflash and this issue was resolved. Also I selected the red file in the file selection process of the firmware upload not the blue file.

I have the same problem when I shoot the programming on the board. I attach a photo. I can’t find the solution. Thanks to everyone!