Everytime I plug in my hat with EM060K-GL, my computer blue screens

Everything was working fine until I updated my firmware, and now… everytime I plug the hat / modem into my PC it blue screens and dies.

This is my modem stats, and I’ve noticed that two USB ports have disappeared from my boot log.

blue screen means that there might be some problems with hardware.
Please check

AT+QCFG=“usbmet”

And which Quectel driver you have installed?

image

Alright so I was able to delete all the ports and network devices to enable the device to connect without crashing my computer, but now the computer doesn’t recognize the AT Ports any more. Is there a driver or something to get so that it can recognize the AT Ports?

I will send you the windows driver.

Thank you
I can see the ports now, but I might be missing one / the DM port has a yellow triangle even I downloaded both drivers.

image

Could you send AT over the Quectel USB AT Port(COM10)?

If you can please check

AT+QCFG=“usbnet”

I get ,2

Please open the device manager.
And try update the driver for the DM port.

So should I re-install the driver again?

I tried the repair driver function in the install, no joy.
I tried the device diag on windows… no luck there either

Please check the usb interface number of the DM port.
It should be 0.

How do I check the USB Interface Number of the DM port, and how do I change it to 0?

I somehow figured out how to get rid of the yellow triangle, but I’m not sure about the USB interface Number.

image

I’m also missing the NMEA port if there is one… and I don’t have connectivity yet.

And is there any unknown device in the device manager?