EP06-E wont get CA on capable tower

Hi Ive got EP06-E running in Mikrotik LHG-R and it works quite well and I can even pass the network address thru to the router. My provider is Three (SMARTY) UK.

However I cannot get CA even though I have verified that the tower supports CA on bands B3,B1,B20 (by connecting my phone to same tower and observing diagnostics tools and speed tests)

Is there some settings I need to use or some way to discover why the module does not get CA?

Module version is: EP06ELAR03A08M4G

Thanks you in advance

Thanks for your query in Quectel forums.
It is recommended that you try to use AT+QCAINFO command to get CA information, thank you.

Thank you, I tried this command but it replys with “OK” and nothing else.

I’d really like to be able to to see if the cell tower is sending CA info to the card - I presume that the tower controls who gets CA and who doesnt?

Please see screen shot

Also it switches between B1 & B3. I have setup band locks B3, B1 & B20

I temporarily placed the dish on a makeshift mast to see if signal was affecting it, and still no CA. I also conducted a speed test to see if this would prompt CA to kick-in but it did not.