EP06-E not detected

I am trying to connect EP06-E module to a desktop PC using a PCIE to mini PCI-E adapter card. Adapter card takes voltage from PCIE connector and is also connected to motherboard via USB for communication. Card works with an old WiFi mini PCI-E module but when I connect EP06-E module to it, it is not detected. Tried Linux, Windows 10 and 11 and still nothing. Please advise.

Hello, if PCIE is not identified, please confirm that the cable is correctly connected and try to install the PCIE driver I provided. I hope it will be helpful to you
Driver link:

Hello. The problem lies with the way the system goes through the Power-On Self Test (POST). I discovered that after tinkering in the BIOS, specifically when changing the speed of the PCIE lanes, the device gets found in Windows. Unfortunately, if I shut down the PC, on the next power on, the device disappears again. My suspicion is that during POST, the system first checks for USB devices and only then gives off power to the PCIE slot. This results in the card being checked while there is still no power going through it. But I guess that is more of an issue with the motherboard BIOS and the adapter card manufacturers. Thank you anyway, there is no issue with the Quectel card.

Hello, I bought a different adapter for my PC and managed the device manager to see the module. But now I am having trouble with connecting to the internet. I can see in events that there is problem with qcusbwwan service -

Device USB\VID_2C7C&PID_0306&MI_04\6&c8cf086&5&0004 had a problem starting.

Driver Name: oem34.inf
Class Guid: {4d36e972-e325-11ce-bfc1-08002be10318}
Service: qcusbwwan
Lower Filters:
Upper Filters:
Problem: 0x0
Problem Status: 0xC00000E5

Can you please help. I tried reinstalling the drivers, did not fix.