EP06-E not connecting to the network after firmware update

Hi,

I’ve updated the module to the EP06ELAR04A03M4G firmware, and it won’t register after this. I’ve tried resetting to factory defaults, different usbnet modes, usb 3.0 mode on and off, but it won’t register.

The output in the QNavigator is
+CGREG: 0,3

And after that there is several errors like this:
+EMM ERROR: 3,15
+ESM ERROR: 3,32

When updating the firmware I’ve connected the module to the PC without antenna and SIM card. May it be that the output circuit is burned?

Thanks,
Fedor

1 Like

Dear Fedor
Thank you for your inquiry in Quectel forums.
For your request, may i know the original version, update tool and tool setting.
you can check the result of AT+CFUN?
Could you share more information: company name and location, and the product application/timeline, which channel to get the module and the firmware package. it seems update failed.

Hi Jeffrey,

Original version was EP06ELAR02A03M4G, I’ve used the Qflash 4.18, the settings were all by default.
AT+CFUN? shows +CFUN: 1

I’m just a private person in Russia, trying to get more out of my 4G connection. I got the module from wifimag.ru, and the update also from them. The module is installed in Mikrotik RBM33G.

Hi Fedor
You can downgrade the FW and check the network status then re-update it again. if still failed, please execute below AT command and check the output message. Of cause, you can feedback to Mikrotik if need, thanks
AT+CPIN?
AT+CSQ
AT+QCFG=“band”
at+qcfg=“nwscanmode”
AT+CGDCONT?
AT+CGPADDR
AT+QENG=“servingcell”
AT+QENG=“neighbourcell”

Hi Jeffrey,

I don’t have the original FW version, could you please provide it?

Anyway, here’s the output of those commands on current firmware:
[2020-07-31 14:38:36:974_R:] AT+CPIN?
[2020-07-31 14:38:36:974_R:] +CPIN: READY

[2020-07-31 14:38:48:462_R:] AT+CSQ
[2020-07-31 14:38:48:462_R:] +CSQ: 23,99

[2020-07-31 14:39:46:545_R:] AT+QCFG=“band”
[2020-07-31 14:39:46:545_R:] +QCFG: “band”,0x8d0,0x1a1880800d5,0x1

[2020-07-31 14:40:10:170_R:] at+qcfg=“nwscanmode”
[2020-07-31 14:40:10:170_R:] +QCFG: “nwscanmode”,3

[2020-07-31 14:40:21:134_R:] AT+CGDCONT?
[2020-07-31 14:40:21:134_R:] +CGDCONT: 1,“IPV4V6”,"",“0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0”,0,0,0,0
[2020-07-31 14:40:21:134_R:] +CGDCONT: 2,“IPV4V6”,“ims”,“0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0”,0,0,0,0
[2020-07-31 14:40:21:134_R:] +CGDCONT: 3,“IPV4V6”,“sos”,“0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0”,0,0,0,1

[2020-07-31 14:40:44:622_R:] AT+CGPADDR
[2020-07-31 14:40:44:622_R:] +CGPADDR: 1,""
[2020-07-31 14:40:44:622_R:] +CGPADDR: 2,""
[2020-07-31 14:40:44:622_R:] +CGPADDR: 3,""

servingcell output is alternating between those 3 states

[2020-07-31 14:41:02:807_R:] AT+QENG=“servingcell”
[2020-07-31 14:41:02:807_R:] +QENG: “servingcell”,“LIMSRV”,“LTE”,“FDD”,,,,,,,,,,,,,,

[2020-07-31 14:46:35:423_R:] AT+QENG=“servingcell”
[2020-07-31 14:46:35:423_R:] +QENG: “servingcell”,“SEARCH”

[2020-07-31 14:46:35:705_R:] AT+QENG=“servingcell”
[2020-07-31 14:46:35:705_R:] +QENG: “servingcell”,“LIMSRV”,“LTE”,“FDD”,65535,65535,FFFFFFFF,0,-1,3,3,3,FFFF,-140,-20,-120,0,0

[2020-07-31 14:46:00:371_R:] AT+QENG=“neighbourcell”
[2020-07-31 14:46:00:371_R:] +QENG: “neighbourcell intra”,“LTE”,*****
[2020-07-31 14:46:00:371_R:] +QENG: “neighbourcell intra”,“LTE”,*****
[2020-07-31 14:46:00:371_R:] +QENG: “neighbourcell inter”,“LTE”,*****
[2020-07-31 14:46:00:371_R:] +QENG: “neighbourcell inter”,“LTE”,*****
[2020-07-31 14:46:00:371_R:] +QENG: “neighbourcell inter”,“LTE”,*****

This is the output from the QNavigator on Windows PC, so it’s not Mikrotik-specific, and it’s the same on the Mikrotik. I just mentioned the Mikrotik as the device where the module was installed.

Configure your APN here

Hey jfrog,

thanks for the hint, I though APN should be set automatically in Windows.
I’ve set it like this (it’s the same as RouterOS sets by default):

+CGDCONT: 1,“IPV4V6”,“internet”,“0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0”,0,0,1,0

but the result is still the same - no registration on network.

what about

AT+COPS?
AT+CEREG?

At the beginning you mentioned

“3” means

Registration denied. The UE is in GMM state GMM-NULL. The GPRS service is
disabled; and the UE is not allowed to attach for GPRS if requested by the user.

Also,

try to change 1 to 0 and when it will be registered check with

AT+CGPADDR
AT+CGCONTRDP

Ok, I’ve changed the IPv4AddrAlloc of the APN, but still no go.
Yes, the CGREG shows 3 at the beginning, but after setting the APN it changes to 0,2, which is a bit better, but still no good. I suppose it behaves as if there is no signal, but CSQ shows 22,99, which is ok, I guess?

AT+COPS? returns 0.

As for
AT+CGPADDR - it shows
[2020-08-01 00:03:57:110_R:] +CGPADDR: 1,""
[2020-08-01 00:03:57:110_R:] +CGPADDR: 2,""
[2020-08-01 00:03:57:110_R:] +CGPADDR: 3,""
as before, and
AT+CGCONTRDP just returns OK

Signal is good.
2 means

Not registered, but MT is currently trying to attach or searching an operator to
register to. The UE is in GMM state GMM-DEREGISTERED or
GMM-REGISTERED-INITIATED. The GPRS service is enabled, but an allowable
PLMN is currently not available. The UE will start a GPRS attach as soon as an
allowable PLMN is available.

Can you try with another SIM?
I would upgrade to the latest fw, just in case something went wrong during the earlier upgrade.

Sure, tried with another SIM, of another operator - no go. I’ve even changed the WWAN adapter, thought maybe the SIM slot was bad, but no, the result is the same.

What’s got my attention though, is that when querying AT+QENG=“servingcell” it always returns some cell, but of not correct operator (not one of two SIMs I have). So I thought that I’ve messed up the band settings or something, and started to look for the way to reset the band settings. And while searching, I’ve stumbled upon this wonderful command AT+QPRTPARA=3 (disclaimer: do not use too often).

After running it everything went back to normal! Module registered immediately, and all is well. I suppose something was messed up in nvram when updating the FW.

Thanks for your help jfrog, you’ve set me on a right path. :slight_smile:

1 Like