EP06-E drops connection every ~90 seconds with Beeline operator

Hello everyone!

I’m trying to solve a puzzle with EP06-E modem connected via USB and with two antennas. The modem is brand new and I don’t have a lot of experiecne with it.

The problem is in that when I use Beeline sim-card with this modem I get disconnect every minute or a little bit longer.

The modem connects to LTE network, the coverage at this place is good (actually I tested two places and the behaviour is the same). Atfer a minute it disconnects and after some time later connects again. Then disconnects and connects back. That repeats infinitely.

When I use other operator (MTS) with the same EP06-E it connects and keeps connection without any problems. When I use Beeline sim-card in ZTE UBS-modem it connects without any problems and keeps very fast connection rate (it gives 60 mbit download and 50 upload).

What I tried to do:

  1. Enable and disable 600/50 mode via AT.
  2. Changed QMI/ECN/MBIM modes.
  3. Fixed connection to only LTE.
  4. Used external power supply for the modem via USB.

Nothing helped. What can be wrong?

One possibility I can think of is that MBN is active and it’s looking for a better fit of MBN file than it can find in its repertoire.

What do these AT commands return?


The commands give:

[2022-01-02 23:21:14:922_R:] OK
[2022-01-02 23:21:33:377_S:] AT+QMBNCFG="LIST"
[2022-01-02 23:21:33:432_R:] AT+QMBNCFG="LIST"
[2022-01-02 23:21:33:432_R:] +QMBNCFG: "List",0,1,1,"ROW_Generic_3GPP",0x06010821,201901151
[2022-01-02 23:21:33:432_R:] +QMBNCFG: "List",1,0,0,"Telstra-Commercial_VoLTE",0x06800118,201904181
[2022-01-02 23:21:33:432_R:] +QMBNCFG: "List",2,0,0,"Volte_OpenMkt-Commercial-CMCC",0x06012064,201907031
[2022-01-02 23:21:33:432_R:] +QMBNCFG: "List",3,0,0,"OpenMkt-Commercial-CU",0x06011510,201706062
[2022-01-02 23:21:33:432_R:] +QMBNCFG: "List",4,0,0,"TW_Mobile-Commercial_VoLTE",0x06800201,201712042
[2022-01-02 23:21:33:432_R:] +QMBNCFG: "List",5,0,0,"Commercial-DT-VOLTE",0x06011F25,201905061
[2022-01-02 23:21:33:432_R:] +QMBNCFG: "List",6,0,0,"Commercial-KT",0x0601270B,201801224
[2022-01-02 23:21:33:432_R:] +QMBNCFG: "List",7,0,0,"Commercial-Reliance",0x06011B34,201904021

[2022-01-02 23:21:33:432_R:] OK
[2022-01-02 23:22:04:488_S:] AT+QMBNCFG="Autosel"
[2022-01-02 23:22:04:542_R:] AT+QMBNCFG="Autosel"
[2022-01-02 23:22:04:542_R:] +QMBNCFG: "AutoSel",1

[2022-01-02 23:22:04:542_R:] OK

But it seems that the modem disconnects from the port during that behaviour. At least QNavigator is not able to communicate with it.

I’d try deactivating MBN completely, do a hard modem reset, and see how you go.

To deactivate:


To go back to the settings you have now:


1 Like

It helped but only partially. After these commands ordinary ping is more or less stable. But if I want to do some SpeedTest or open a large web-site I notice the same behaviour - modem disconnects and it seems that it reboot internally (no external site ping nor modem interface).


After a day of testing have to commit that the solution didn’t help. The behaviour is the same. :frowning:

This is behaviour I associate with inadequate power supply. I realize you’ve already tried to address that possibility, but I would have another look.

What sources of power is the modem using now?

I use an USB 2.0 hub. I feed it via USB with an external USB 2A powerful Samsung original power supply (a cable is inserted into USB power supply and the other end is inserted into a USB-port of the USB-hub).

With the external power supply I notice the voltage at the hub at around 5.2V with the modem or without it. And when the modem is enabled and the power supply is not connected the voltage is dropped back to 4.5-4.2 V.

Without the external power supply similar behaviour was noticeable with the second cellular operator. The way of power supply via USB-port is legitimate and it works :slight_smile:

Look at the USB cable from hub to modem. Ideally it will be as short as practicable, and have heavy-gauge wires for power (20 or 22 AWG).

Other than that, I’m out of ideas for the moment.

I did one more experiment.

Yesterday I was in a rural area and Beeline operator in ZTE modem gave me easily 60 mbit. And I had some problems with EP06-E modem.
Today, I’ve returned to my city where EP06-E can provide me with only 13 mbit with Beeline operator. And it works well without any external power adaptor.

I also used another power adaptor that is designed especially for power feeding via USB. It has voltmeter and amperemeter. The maximum power consumption that I managed to notice was 0.6A

As to the cable - I use a brand new Hama cable that is 1.5 m length but is thick enough. I also use 1 m length cable to connect the modem to the hub. It is not so thick but not also so thin. Just an ordinary MicroUSB cable.

If the problem is in the power supply then it can be also inside the modem adapter where 5V ara transformed into 3.3V.

One more thought: in my rural area the modem was in around 150 m from the Operator’s base station (through a metallic roof but anyway). Could it be a kind of overload with the signal power?

If you haven’t already, please try replacing that one.

I’ve changed several cables and found out that the modem works only with the original cables that came with the modem and with one more USB2 cable. I also found that the modem works well only when USB 2.0 cable is used and the hub is connected into USB2 port.

I’m not able to check the modem behaviour at the rural area spot where I have extremely good connection. Will monitor the behaviour of the modem that is connected to Raspberry via power USB hub.

Check with AT+CBC - I guess you will see different results with different cables.

1 Like

Tried to check the voltage with the external power and without it (but the same cable). It is the same in both cases 35xx
But when I disconnected the external power the modem disconnected and refuses to connect back.

The important reading is the one taken while the modem’s transmitter is operating. So during a speedtest for example.

Checked it under load (Speedtest and YouTube) - the same thing 35xx V. But as I mentioned above that is under poor connection conditions. Speedtest gives around 10 mbits. So I need to test it more with better conditions. The closest time is Monday when I can do checks at at least different conditions.

Are you always getting disconnected under load? Independent of signal strength?

Poor signal can have a dramatic impact on modem power requirements. The modem transmitter has to ramp up power so that it can be heard by the BTS/tower servicing it.

I learned long ago to use modem USB cables having at least 22AWG power wires. 20AWG is even better (thicker), but are harder to find.

In current situation no. The modem is as stable as it should be. It works without any interruption independently to its load.

But I think that at better signal strength it can consume more energy due to enabling some aggregation features and high-speed data exchange.

To date what helped or not:

  1. Using external power
  2. Using good cables (not sure that the old one was a bad one, they looks similar by thickness)
  3. Not using USB 3.0 cables (proved)
  4. Not using USB 3.0 ports at Raspberry Pi (proved).
  5. AT+QMBNCFG=“Deactivate” && AT+QMBNCFG=“AutoSel”,0 (probably but not sure)
  6. Very good signal strength may lead to interruption (need to be re-checked).

Unless I’m mistaken, the EP06-E supports CA only on the downlink, and not the uplink. So the effect of CA on power consumption is minimal.

I’ve checked the following at the target place:
These commands AT+QMBNCFG=“Deactivate” && AT+QMBNCFG=“AutoSel”,0 are not neccesary. It works without them.

Better (but not the best) signal doesn’t lead to some problems. The modem gives up to two times better signal than ZTE-USB modem.

Checked voltage at the load with 20 mbit - the same 35xx