EP06-E and not work DHCP in usbnet=1

Good day. I used Ep06-E complete with Mikrotik RBM33G in QCFG mode = “USBNET”, 1. Then AT commands, led the module to the fact that he stopped issuing a DHCP address for the lte interface (in the range 192.168.225.xx) in mikrotik. Separately, there is an interface lte, at startup it connects to the network, but there is no communication with the interface. In ppp-out mode it connects, there is a connection.

Nearby lies the second EP06-E module, comparing responses to AT commands, I do not see a difference in answers. The only difference is that in the USB device window, the working (second) module is called Quectel, the limited working one is called LTE-A. PID / VID are the same.

What do you advise ? How do AT commands return the modem to normal operation?

Dear Fog168,
Thanks for your inquiry in Quectel forums.
Could you help to provide the module firmware version or the exact AT command you used ? I have checked the command, cannot find “USBMODE”, Please help to double check it. From your description, you want to change the module network card type, if that you can try the command AT+QCFG=“USBNET”. Thanks!
[2019-12-11_09:23:00:830]+QCFG: “gprsattach”,(0,1)
[2019-12-11_09:23:00:830]+QCFG: “nwscanmode”,(0-8),(0,1)
[2019-12-11_09:23:00:830]+QCFG: “servicedomain”,(0,1,2),(0,1)
[2019-12-11_09:23:00:830]+QCFG: “roamservice”,(1,2,255),(0,1)
[2019-12-11_09:23:00:830]+QCFG: “band”,(0-200),(0-7FFFFFFFFFFFFFFF),(0-7FFFFFFFFFFFFFFF),(0,1)
[2019-12-11_09:23:00:830]+QCFG: “rrc”,(0-4)
[2019-12-11_09:23:00:830]+QCFG: “msc”,(0-2)
[2019-12-11_09:23:00:830]+QCFG: “sgsn”,(0-2)
[2019-12-11_09:23:00:835]+QCFG: “hsdpacat”,(6,8,10-24)
[2019-12-11_09:23:00:835]+QCFG: “hsupacat”,(5,6)
[2019-12-11_09:23:00:835]+QCFG: “pdp/duplicatechk”,(0,1)
[2019-12-11_09:23:00:835]+QCFG: “ledmode”,(0,1)
[2019-12-11_09:23:00:835]+QCFG: “usbid”,,
[2019-12-11_09:23:00:835]+QCFG: “usbee”,
[2019-12-11_09:23:00:835]+QCFG: “usbnet”,<0-2>
[2019-12-11_09:23:00:835]+QCFG: “usbcfg”,,,,,<at_port>,,,
[2019-12-11_09:23:00:846]+QCFG: “urc/ri/ring”,(“off”,“pulse”,“always”,“auto”,“wave”),(1-2000),(1-10000),(1-10000),(“off”,“on”),(1-5)
[2019-12-11_09:23:00:846]+QCFG: “urc/ri/smsincoming”,(“off”,“pulse”,“always”),(1-2000),(1-5)
[2019-12-11_09:23:00:846]+QCFG: “urc/ri/other”,(“off”,“pulse”),(1-2000),(1-5)
[2019-12-11_09:23:00:846]+QCFG: “risignaltype”,(“respective”,“physical”)
[2019-12-11_09:23:00:850]+QCFG: “urc/delay”,(0,1)
[2019-12-11_09:23:00:850]+QCFG: “agps/string”,(0,1)
[2019-12-11_09:23:00:850]+QCFG: “ltesms/format”[,(0,1)]
[2019-12-11_09:23:00:850]+QCFG: “ModemRstLevel”,(0,1)
[2019-12-11_09:23:00:850]+QCFG: “ApRstLevel”,(0,1)
[2019-12-11_09:23:00:850]+QCFG: “noauthcheck”,(0,1)
[2019-12-11_09:23:00:850]+QCFG: “nwscanmodeex”,(1-63)
[2019-12-11_09:23:00:856]+QCFG: “pcmclk”,(0,1)
[2019-12-11_09:23:00:856]+QCFG: “tone/incoming”,(0,2)
[2019-12-11_09:23:00:856]+QCFG: “sim/recovery”,(3-300),(0,5-300),(0,300)
[2019-12-11_09:23:00:856]+QCFG: “urc/cache”,(0,1)
[2019-12-11_09:23:00:856]+QCFG: “thermal/modem”[,,,]
[2019-12-11_09:23:00:856]+QCFG: “thermal/limit_rates”[,]
[2019-12-11_09:23:00:856]+QCFG: “lte/bandprior”,(1-43),(1-43),(1-43)
[2019-12-11_09:23:00:862]+QCFG: “vts/async”,(0,1)
[2019-12-11_09:23:00:862]+QCFG: “urc/ri/pin”,(“uart_ri”,“uart_dcd”)
[2019-12-11_09:23:00:862]+QCFG: “stkauto/setupmenutr”,(0,1)
[2019-12-11_09:23:00:862]+QCFG: “imsreg/iptype”,(0,1)
[2019-12-11_09:23:00:862]+QCFG: “sim/onchip”,(0,1)
[2019-12-11_09:23:00:862]+QCFG: “powerup/regctl”,(0,1)

[2019-12-11_09:23:00:862]+QCFG: “volte_disable”,(0,1)
[2019-12-11_09:23:00:862]+QCFG: “sim/clk_freq”,(0,1)
[2019-12-11_09:23:00:869]+QCFG: “attach/ims”,(0,1)
[2019-12-11_09:23:00:869]+QCFG: “diversity/config”,<0-5>,<0-7>
[2019-12-11_09:23:00:869]+QCFG: “fast/poweroff”,(0,1)
[2019-12-11_09:23:00:869]+QCFG: “sarcfg”,,,<max_power>,<row_grads>
[2019-12-11_09:23:00:869]+QCFG: “redir/3gtolte”,(0,1)
[2019-12-11_09:23:00:869]+QCFG: “256qam”,(0,1)
[2019-12-11_09:23:00:869]+QCFG: “Feature_Switch_Flag”,(0,1),(0x01 – 0xFFFFFFFF)
[2019-12-11_09:23:00:876]+QCFG: “estk/send_sms”,(0,1)
[2019-12-11_09:23:00:876]+QCFG: “poaccept”,(0,1)
[2019-12-11_09:23:00:876]+QCFG: “qcautoconnect”,(0,1)
[2019-12-11_09:23:57:008]+QCFG: “usbnet”,0
[2019-12-11_09:24:47:150]Revision: EP06ELAR03A06M4G

Hello everybody!

Sometimes modems EC25, EP06-E when working in mikrotik routers do not give a message to allocate a dhcp address for the router.


Dear Fog168,
This command AT+QURCCFG=“urcport”,“usbat” is used to set the URC report port.
And about the question that “do not give a message to allocate a dhcp address for the router”, could you share more information with us the exact phenomenon. Thanks!

@fog168, The dhcp-client is not usable here !. Ignore it.
When the module will connect to ISP then the interface will bring Running status and you see the IP>Address and IP>Route with the data, without dhcp-client.

Dhcp-Client is used for lte1 on USB Stick modems!.

For now better is for you change the lte1 interface NAME from your own R11e-LTE to some other like lte1, lte1-wan1 etc.
Please use a ONLY default APN and that default APN set in lte1 interface!.
After this you can check the logs again.

I solved my problem using Ep06-E and a Mikrotik router.

I know that this is an old post - but you report having solved your problem, but not what the solution was. I’m seeing a similar issue on a friend’s modem. Would you mind relating what your actual problem turned out to be and how you solved it? Thanks!

Tell me how you solved this problem?

If you’re not getting a response to AT commands you can try the following:

wait a minute before sending the rest of the commands
AT+QCFG=“usbnet”,0 < QMI/PPP/Default
AT+QCFG=“usbnet”,1 < ECM
AT+QCFG=“usbnet”,2 < MBIM

Restart the router/device and test the AT commands.

If unable to send the above commands you can try logging into the router/device via SSH (search online on how to), then list the tty devices:

ls /dev/tty*

Try all the “ttyUSB” devices:

screen /dev/ttyUSB 9600

Send an “AT” by itself and make sure to get an “OK” response before sending the commands on top.