EP06-A will not connect to AT&T

I’m using an EP06-A in a Mikrotik LHG R. I have put 3 of these configurations into production and now am having failure on two with the exact same firmware and configuration.

There is some further detail I posted that is relevant to the router config on the Mikrotik forum so feel free to view this as well:

EP06A firmware version: EP06ALAR02A08M4G

  • Also tried: EP06ALAR02A08M4G_01.003.01.003

I’ve tried:
Disabling 3g (LTE only)
Setting auto APN
Setting manual APN (broadband)
Allow Roaming
Disable Roaming
Manual band set (used band 66 because this was the band that the previous units connected to in the lab)
Auto band with all allowed

I worked with Mikrotik support and they said the EP06-A is failing to connect with the error:
Jul/06/2022 07:41:13 lte,debug lte1 mbim: >>> E service: conn_ext, command: lte attach config, error: INVALID_PARAMETERS

Mikrotik support said the error stems from an incorrect configuration for the provider. I have the APN set to “broadband” which is the proper APN for the carrier (AT&T). I have tried different SIM cards and used the same test SIM cards in other equipment models (they work in other devices). The SIM card is detected and ICCID can ben read by the Mikrotik / displayed in the UI.

Can I send an AT Command to the modem to output the configured APN (so I can verify the UI setting in the Mikrotik is actually being applied properly to the modem)?

thank you

1 Like

Quectel, will you review this?

Try this command. You may need to reboot afterward.

/interface lte at-chat lte1 input=“AT+CGDCONT=1,\“IPV4V6\”,\“broadband\””

You can also double check your settings. APN should be “broadband”. Allow Network APN should be DISABLED. IP Type should set to Auto. And Allow Roaming should be DISABLED on the LTE interface.

I’m not sure of an AT command to see the configured settings.

Great, thank you Nilpo.

I have two of these I’ve been testing. The two sets of test hardware are two different EP06, two different LHG R, two different SIM, SIMs activated on different AT&T plans.

On the first test unit, it has been sitting at my desk powered up. I reset the power to the EP06 and ran the command you sent, then it immediately connected. I thought this had certainly resolved the issue and moved on to the 2nd test unit to try it there as well.

The second unit was powered off. I powered it up to start testing again and it immediately connected without making any change. This makes me wonder if there was something on the local AT&T tower preventing these from properly registering.

I am mystified now though since I’ve been trying different settings for the past week or two trying to make these two work and one was fixed by manually setting APN via the AT command you sent (I had broadband selected as the APN in the Mikrotik config with IPV4 set as the type and ‘Allow Roaming’ selected although I had tried many different combinations of the IP type and roaming setting in the past).

Now, when I update the APN / change settings in the Mikrotik UI on either test unit, it will always reconnect properly (even with allow roaming, or IPV4 only set). Very strange. Next time I have a failure, I’ll try that command again.

After provisioning many more units, we run this command and it always resolves the issue with these devices not connecting to AT&T. Somehow, the Mikrotik seems to have trouble telling the EP06-A to set the “broadband” APN. It is still a mystery why the Mikrotik can’t set AT&T’s APN properly but can set other carrier APNs without the same problem.