EP-06-E wont work after "successful" firmware upgrade

Today I upgraded my EP06-E with EP06ELAR04A20M4G that I got from @herbert.pan-Q.
After I upgraded the module seemed dead. Didn’t show on lsusb.
The old version that worked was EP06ELAR03A08M4G.
Found the test points to do firmware recovery and when restarting the card with those it shows up as:

Bus 001 Device 002: ID 05c6:9008 Qualcomm CDMA Technologies MSM QUSB__BULK

I tried reflashing the firmware again. Both using QFirehose V1.2 and V1.4.9.
But it still only shows any sign of life when going in to recovery mode.

Edit: Also tried with QFlash_Linux_2.0 and LTE_QFirehose_Linux&Android_V1.0.3

@herbert.pan-Q is it possible to get a different firmware for the EP06-E to try with?

I flashed 3 of my ep06-e with that firmware and it was allsuccessful. I used qflash v 6.

Attaching the log from flashing
qfirehose_1691420433.log.txt.zip (3.5 KB)

1 Like

@herbert.pan-Q: Can I please have the latest version of the flashing tools (both windows and linux) and a different version of the firmware to try with?

I solved it.

  1. Put tape over pin 23+25 and 31+33 to block usb3 pins.
  2. Replaced kerneldriver qcserial with the option driver
  3. Connected to the modem and sent the at-command to disable usb3 (AT+QUSBCFG=“SS”,0)
  4. Removed tape from card.
  5. Profit

It would seem that the old firmware I was running didn’t use usb3.

1 Like