EM060K-GL -- physical SIMs not recognized

We have a machine with an on-board SIM slot.

We are running Ubuntu 22.04 LTS fully updated.

We are able to use this on-board slot with the EM06-A units that we have used previously. (works great, btw :slight_smile:) The physical SIMs we installed are all recognized by it โ€“ both the North American and the Brazil SIM (we know the Brazil SIM wonโ€™t work properly with the EM06-A but the system still recognizes the SIM).

Neither of these SIMs are recognized with the EM060K-GL installed (we have tried 3 distinct units).

We even tried changing slot priority on the EM060K-GL (JIC) which had no effect.

The SIMs are from Hologram for IoT data upload.

Here is the equipment, status and slot reports from mmcli (equipment id redacted):

  Hardware |            manufacturer: Quectel
           |                   model: EM060K-GL
           |       firmware revision: EM060KGLAAR01A11M2G
           |          carrier config: ROW_Generic_3GPP
           | carrier config revision: 08010809
           |            h/w revision: EM060K-GL
           |               supported: gsm-umts, lte
           |                 current: gsm-umts, lte
  Status   |                   state: failed
           |           failed reason: sim-missing
           |             power state: on
  SIM      |          sim slot paths: slot 1: none
           |                          slot 2: none (active)

We have looked for firmware updates in case that was an issue but were unable to find any.

Any ideas or troubleshooting we should try?


@Support-team @herbert.pan-Q is there possibly a firmware update we need to apply?