EG915U won't register since firmware update


We tested our EG915U-EU modems on Vodafone Ireland and they worked perfectly with this firmware:

Jan 17 2022 14:16:49
Authors: QCT

Since updating to this version (below) we can no longer register on Vodafone Ireland unless we set the modem to 2G with AT+QCFG=“nwscanmode”,1,1. I suspect this problem is not isolated to just Vodafone Ireland. I can confirm later.

Apr 25 2023 12:16:09
Authors: QCT

When the scanmode is left to auto we get ‘LIMSRV’ on the updated modems.

Non-updated modem:
+QENG: “servingcell”,“NOCONN”,“LTE”,“FDD”,272,01,24A5249,66,9460,28,3,3,CF6E,-87,-15,-56,48,34

Updated modem:
+QENG: “servingcell”,“LIMSRV”,“LTE”,“FDD”,272,01,24A5241,4,300,1,5,5,CF6E,-111,-16,-77,46,10

We’re using the same SIM and same hardware. The AT+QCFG=“band” settings are identical.

Using this SIM in a Qualcomm EG91 gives the following results:

+QENG: “servingcell”,“NOCONN”,“LTE”,“FDD”,272,01,24A5241,4,300,1,5,5,CF6E,-101,-15,-66,-3,20

This is the kind of think we saw with the EG91-E when we had the wrong binary file selected. It was easier to just send:


…to restore it to default. This command is not implemented in the EG915U. Is there an equivalent? This would be consistent with 2G working OK.

AT&F may work. This unit is working now so I’ll roll it out to a few more.

I solved same problem after chage firmware version to EG915UEUABR03A01M08_01.206.01.206 version.
The solution is easy.
You have to set APN from your sim provider first: AT+QICSGP=1,1,“your_apn”
Modem remember it.