EG915N-EU USB problem

While working with the EG915N-EU module, I came across the following problem. When I tried to run the command: AT+QCFG=“usbcfg” I got a response from the module: +CME ERROR: 4.
What is it caused by? Also after typing AT+QCFG=? I have this list of possible commands to choose from:
+QCFG: “gprsattach”,(0,1)
+QCFG: “nwscanmode”,(0-1,3)
+QCFG: “nwscanmodeex”,(0-28)
+QCFG: “nwscanseq”,(0-12)
+QCFG: “servicedomain”,(0,1,2),(0,1)
+QCFG: “roamservice”,(1,2),(0,1)
+QCFG: “roamserviceex”,(0-3)
+QCFG: “urcdelay”,(0-120)
+QCFG: “urc/cache”,(0,1)
+QCFG: “urc/cache/datamode”,(0,1)
+QCFG: “urc/ri/ring”,(“off”,“pulse”),(5-2000),(1-5)
+QCFG: “urc/ri/smsincoming”,(“off”,“pulse”),(5-2000),(1-5)
+QCFG: “urc/ri/other”,(“off”,“pulse”),(5-2000),(1-5)
+QCFG: “risignaltype”,(“respective”,“physical”)
+QCFG: “usbnet”,(1,3)
+QCFG: “usbid”,(0-65535),(0-65535)
+QCFG: “usbmanufacturer”,<manufacter_name>
+QCFG: “usbversion”,(0-1)
+QCFG: “usbphy”,(0-3)
+QCFG: “usbifc”,(0-2),(0-2)
+QCFG: “usbdtd”,(0,1),(0-64),(0-64)
+QCFG: “usbauto”,(0,1)
+QCFG: “uart2ipr”,(4800,9600,19200,38400,57600,115200,230400,460800,921600)
+QCFG: “ppp/termframe”,(0,1)
+QCFG: “ppp/dcd”,(0,1)
+QCFG: “iprecovery”,(0,1)
+QCFG: “acq/query”,MCC,MNC,(1-3)
+QCFG: “acq/insert”,MCC,MNC,(1-3),(0-99999),…
+QCFG: “acq/clear”,(1-3)
+QCFG: “acq/update”
+QCFG: “nwoptmz/acq”,(0,1),(60-4147200)s
+QCFG: “airplanecontrol”,(0,1)
+QCFG: “ltedftcid”,(1-15)
+QCFG: “cmux/channel”,(0-4)
+QCFG: “fota/cid”,(1-15)
+QCFG: “fota/times”,(0,(30-180)
+QCFG: “Feature_Switch_Flag”,(0,1),(1-FFFFFFFF)
+QCFG: “ntp”,(1-10),(5-60)
+QCFG: “pcmclk”,(0,1)
+QCFG: “ledmode”,(0-2)
+QCFG: “ppp/remoteip”,(0,1)
+QCFG: “dns/proxy”,(0,1)
+QCFG: “nat”,(0-1)
+QCFG: “dhcp/cfg”,(0),(0-255)
+QCFG: “netmaskset”,(0,1),
+QCFG: “cmux/urcport”,(0-4)
+QCFG: “tone/incoming”,(0-2),<file_name>
+QCFG: “creg/emergency”,(0,1)
+QCFG: “pdp/retrytimes”,(0-10)
+QCFG: “csqtype”,(0,1)
+QCFG: “usbnetmac”,
+QCFG: “ncell/priority”,(0-1)
+QCFG: “csqgpiodisp”,(0,1)
+QCFG: “usb/nema”,(0,1)
+QCFG: “ims”,(0-2)
+QCFG: “apready”,(0,1),(0,1)
+QCFG: “sleepind/level”,
+QCFG: “ipc/server_type”,(0,8)
+QCFG: “ipc/pdpcid”,
+QCFG: “ipc/close”
+QCFG: “tautype”,(1-3)
+QCFG: “mifilink”,(0,1)
+QCFG: “urc/ri/pin”,(“uart_ri”,“uart_dcd”,“uart_wakeup”)
This list is slightly inconsistent with what is described in the EC2x&EG2x&EG9x&EM05 Series QCFG AT Commands Manual.
What does this difference mean?

means Operation not supported, that should be available in the AT commands guide

“EG915” does not match “EG9x” pattern, you’re checking the wrong manual.

Can you tell me what instruction should I use? All the manuals I use were downloaded from the Quectel website after searching for my module…

First of all, I do not understand what you tried to achieve with that command. People could advise something if they knew the goal.
I never seen a command manual for EG915N, the closest was EG915U. You probably need to request it from Quectel directly.

My goal was to check which USB interfaces the device has enabled because I had a problem with starting the USB transmission between the STM32F2 and the EG915 chip.
Although the transmission was successful, I still don’t know how to check without using the AT+QCFG=“usbcfg” command what are the settings of individual interfaces.

I don’t think this modem has the mechanism to enable or disable USB interface(s), so I see no reason to check that. Quoting the manual (for other modem though):

EC200U and EG915U series modules AT command interface includes two USB ports (USB MODEM port
and USB AT port) and one main UART port. The main UART port and two USB ports support AT
command communication and data transfer.

My understanding those interfaces are just there, the interface configuration is hardcoded.