EG912Y firmware upgrade problem

I have a EG912Y Revision: EG912YEUAAR01A08M16 that I want to upgrade at EG912YEUAAR01A11M16_01.001.01.001 but the firmware dose not want to update.
I followed the guide Quectel_QFlash_User _… paragraph
I have tried with both “USB AT PORT” and “Quectel Download Port” by shorting the BOOT pin to PL_1V8V.

With “Quectel Download Port” I followed these steps:

  1. power up the module and short-circuit the BOOT pin to PL_1V8V,
  2. I opened QFlash (run as administrator),
  3. I selected the firmware package

Now, the guide tell: “wait for the prompt " device is ready to be enabled
manually\n”} before clicking the “Start” button to upgrade" but this message does not appear.

The message that appears is: “received all devices closed message.\n”}

What am I wrong ?
what can I check ?

Other info:
1)Under windows device manager I can see the Quectel Download Port on COM30.


2)I have installed this driver: Quectel_ASR_Series_UMTS<

Thank you and best regards,

Hi Stefano
You need to decompress, and then select the corresponding firmware to download through com30

fist thank you very much for your reply.

But I have a question:
after decompressed the .zip which file should I take?
In the folder decompressed I have three items, one is a folder EG912YEUAAR01A11M16, other are EG912YEUAAR01A11M16.json and

I tried with but the update doesn’t start.
The following image shows what happened if I try to update the module with file.

Thanks in advance for your help,


OK, I solved !!!
Thank you and best regards,

HI Stefano
Thanks for your feedback