EG91 LTE and GNSS simultaneously

I am having a problem to get a GNSS fix with EG91-EX.
Could it be possible that there is a problem getting GNSS data while having a LTE MQTT session open on the same module?

Hello @jan ,
I don’t understand what you mean very much for the time being. Can you elaborate more?
Thanks & Best Regards.

The EG91-EX module has 2 basic functions:

  1. 2G/3G/4G modem
  2. GNSS Positioning

The modem is working fine, I use it to have a connection between the module and a server over IP and MQTT.
The GNSS however does not detect the satellites, I always get CME error 516 (not fixed now).
I instruct the module to do GNSS positioning while having the MQTT connection active.
So I was wondering: could it be that the EG91 module is not doing GNSS functions while the 4G modem is active? Should I stop transmitting packets while trying to get a GNSS location?

Dear Jan
Would you please confirm if MQTT is not activated, can GNSS locate?

It seems that I do not get a fix even when MQTT is not active.
I tried several antennas, but still no result. Are you sure that the module supports this?
I use revision EG91EXCAR08A0411G

Can you please confirm that this module ( EG91EXGAR08A04M1G ) supports GNSS?
Please provide support.

Dear jan
1.It supports GNSS, can you open NMEA sentences? If yes, please provide NMEA log.
2.Please provide the sending instruction
3.Please provide the schematic diagram of the GNSS antenna part.

Best Regards

Hi Albert.
The system is entirely controlled by a microcontroller through UART communication. I do not use the USB port for NMEA logging.
The following messages are send in sequence through UART:
char *qecho = “ATE0\r\n”; //echo off
char *qgon = “AT+QGPS=1\r\n”;
delay 30 seconds
char *qgstat =“AT+QGPS?\r\n”;
delay 30 seconds
char *qgconf = “AT+QGPSCFG=“outport”,“none””;
char *qqcfg = “AT+QMTCFG=?\r\n”;
char *qgloc = “AT+QGPSLOC=0\r\n”; (repeated every minute)
The first time I get response CME error 501, the consecutive 30 minutes I get CME error 516 as answer.

The antenna schematic is a copy of the one described in the EG91 Hardware design document.

Dear jan
After you connect the GNSS antenna, place it outdoors to receive the GNSS signal, and then send the command: AT+QGPSGNMEA=“RMC” to get the positioning information.

Hi Albert.
I tried AT+QGPSGNMEA=“RMC” with two different LNA Antennas.
The result is always:


The reply editor eliminated commas: there are 2 commas before the V and 10 commas between V and N

What else can I try?

Hi Albert, please provide further help.

Dear jan
If there is no gnss signal indoors, take the GNSS antenna for outdoor testing;
Please provide as much nmea log as possible for our analysis. RMC, GSV, GSA and other sentences.

Hello Albert.
I get this as GSV sentence:

" +QGPSGNMEA: $GPGSV,2,1,06,10,20,13,35,14,23,20,22,160
+QGPSGNMEA: $GPGSV,2,2,06,23,32,24,26,1
OK "

There are two things:

  • azimuth and elevation are not filled-in. Is this normal or a sign that these satellites are not locked?
  • how come that the module sees 6 satelites but does not provide a fix?

For RMC Sentence, I always get this:



Repeating commas are deleted by the editor…

Has anybody succeeded in getting GNSS making reliable fixings with the EC91-EX module?
If yes, please let me know how to do this>

Please provide further support

I’m encountering the same problem. Can you provide support? @Albert.Liu-Q @vic.xie