EG25-G Specific command returns ERROR

Hello there,

I came across an error that I think it shouldn’t be happening.
After executing the command AT+QINDCFG=? I receive this:

+QINDCFG: "all",(0,1),(0,1)

+QINDCFG: "csq",(0,1),(0,1)

+QINDCFG: "smsfull",(0,1),(0,1)

+QINDCFG: "ring",(0,1),(0,1)

+QINDCFG: "smsincoming",(0,1),(0,1)

+QINDCFG: "act",(0,1),(0,1)

+QINDCFG: "ccinfo",(0,1),(0,1)

That is totally normal and confirms (I think…) that the command is valid for this model and firmware.

When I try to execute AT+QINDCFG=“csq”,1,1 or any other option I always get “ERROR”.

Is there anything I’m missing?

Thanks in advance.

Hi, I tried using AT+QINDCFG=“CSQ” on EG25G,1,1, return OK. I think we can check whether the symbol format is correct. If not, please tell me the firmware version you use, and I will try to test again with the same version.


Here’s the result for all the commands

Thanks for your time.

Hello, I have confirmed that we are using the same firmware version. May I ask what purpose you use this command, if you want to see the signal strength, you can use AT+QENG=“SERVINGCELL”, this command is more complete.

I wanted to receive that information as an URC cause if I use the “ATD” command to make a call, any other command will cancel the ATD process. For now I’m using QUIND command manually, and when I start a call, I stop sending any message.

So for now I have a workaround for this problem.

Anyway, how is it possible to have the same HW and firmware and have this problem?

Is there any software to test functionality for this modem?

Thanks again.

Hello, I am not sure whether it is the debugging tool or not. Could you please give me your email address? I will send you our commonly used debugging tool QCOM. Try it with this tool.

Done, check you dm’s.


Hi the tool has been sent, please check. You can try it out, and we’ll talk to you if there’s a problem.

Best wishes

Hello again,

The command with this tool works fine. I’ll look further into this to find a solution and post it here.


OK, wish you all success.

Problem solved.

For some reason is not the same doing an “echo cmd > terminal” than doing it with minicom or you specific SW. Most commands work fine but others don’t. The reason behind it I have no idea.