EG25-G Outgoing call hangs itself by sending other AT commands

Hello there,

I’m using the “CIND?” command to check the signal strength and service status.

When I receive a call, I can still query this command and everything works as intended. But if I query this command while a try to make a call originated on the EG25-G, the call will hang itself.

Is this a normal behavior?

Thanks in advance.

Checking again the documentations clearly says that…

So I will avoid sending any command until the connection has been made.

The real problem is with the outgoing call, once is connected, I can hear a “pop” sound and the audio does not work on any direction. But if I pick an incoming call, everything works perfect.

I’ve been struggling with this problem for months, any help will be appreciated.

Thanks in advance.

Hi, I have seen this problem. I hope QCOM can bring you new solutions. Please let me know if you have any problems.

Hello again,

I tried using the ATD command with your software but the problem remains the same. When receiving the call the audio works well both ways, when originating the call (just using ATDXXXXXXXXX), if we pick up the call on the phone, we heard a “pop” sound on the phone and that’s it.

Is there a way we can debug this?

Thanks again

Hello, have you changed another sim card for testing? Since there was no such problem in my test, I wonder if it is related to the carrier.

Hello, I just tried a different one, same exact behavior. I’m completely lost on this one.

Edit: Tried a third just in case. Same result

I’m not sure if is a configuration problem, here’s the result from my at&v command. Also, how can I check what this numbers mean?


This is really an unusual phenomenon and I don’t understand it at the moment.

I feel that the display is not complete, can you take a complete picture? This isn’t a QCOM command, is it?

Yes, the display is complete.

This is my system (raspberrypi) and the EG25-G I have on that system.

And this is another EG25-G on a Windows PC using QCOM.

Hello, I don’t have all the explanations for this, you need to know which meaning, I will look it up.

I found the solution.

I only had to add semicolon character to the ATD command… I didn’t know it was necessary and much less that the outcome was no sound for the call.

Is this the expected behavior?

Thanks again.

The dial-up command requires a semicolon, like this ATDxxxxxxx;