EG25-G GNSS GpsOneXtra


I’m following the Quectel_EC25EC21_GNSS_AT_Commands_Manual_V1.1.pdf but when excecute the command AT+QGPSCFG=“nmeasrc”,1 gives me an error +CME ERROR: Invalid parameter

and then sends this:
[2020-07-06 12:14:09:461_R:] AT+QGPS=1
[2020-07-06 12:14:09:468_R:] OK
[2020-07-06 12:14:22:639_S:] AT+QGPSLOC?
[2020-07-06 12:14:22:672_R:] AT+QGPSLOC?
[2020-07-06 12:14:22:672_R:] +QGPSLOC: 161422.0,2831.0312N,08114.8888W,0.8,30.5,2,225.13,0.0,0.0,060720,08

[2020-07-06 12:14:22:672_R:] OK
[2020-07-06 12:14:32:394_S:] AT+QGPSEND
[2020-07-06 12:14:32:444_R:] AT+QGPSEND
[2020-07-06 12:14:32:444_R:] OK
[2020-07-06 12:14:39:606_S:] AT+QGPSCFG=“nmeasrc”,1
[2020-07-06 12:14:39:610_R:] AT+QGPSCFG=“nmeasrc”,1
[2020-07-06 12:14:39:611_R:] +CME ERROR: Invalid parameter

[2020-07-06 12:15:27:120_R:] +QGPSURC: “xtradataexpire”,0,“1980/01/05,19:00:00”

[2020-07-06 12:15:27:120_R:] DSR:0 CTS:0 (RI:1) DCD:0

[2020-07-06 12:15:27:191_R:] DSR:0 CTS:0 (RI:0) DCD:0

can somebody help me?

Dear Vevisu,
Please check the following latest document. Thanks!
Quectel_LTE_Standard_GNSS_Application_Note_V1.2.pdf (322.1 KB)

hi Kyson,

I’ve tried with the example section 3
this is what i got
AT+QGPSXTRADATA?+QGPSXTRADATA: 0,“1980/01/05,19:00:00”

AT+QFUPL=“RAM:xtra2.bin”,60717,60 CONNECT
+QFUPL: 28,0


+CGREG: 1,“331C”,“ACCDC03”,7

+QGPSURC: “xtradataexpire”,0,“1980/01/05,19:00:00”

+CGREG: 1,“331C”,“ACCDC0A”,7

+CGREG: 1,“331C”,“ACCDC03”,7

also how is this connected with the network? should I active the PDP context? I have tried also that but I’m not having any results could you please help me?

Sorry i can not see you have follow up the following steps to test it. In your log, there have lack of the following two commands. Please just follow up the examples. Thanks!