EG25 - cannot query timestamp with AT+QLTS

EG25 is connected and online, but AT+QLTS returns “”.


hi herbert,
thank you for your support.
My results:

what can I do to get the time synchronized through network?

You first execute the following command:


second step:


Try it and see if you can get it right

+QLTS: “”


… but no time

Try “AT+CCLK?” to see if you can get the time, otherwise there may be an exception on the network

+CCLK: “80/01/06,04:16:43+00”

…does this mean 1980?

This is unbelievable, I think it may be a mobile network issue, I suggest you check whether your mobile network has been properly registered and successful, if the problem still exists, then update a new version of the firmware.

hi, herbert:
the mobile network is properly registered, as I do have internet-connection via the modem.
is it possible that the network provider does not support time synchronization service?

If the network registration is normal, the base station will issue a synchronization time to the terminal, which is the latest synchronization time obtained by the module. Therefore, the possibility of not being supported by the network provider is relatively small. If conditions allow, it is suggested that you change the SIM card of another provider and try again!

hi, herbert:
unfortunately it is NOT possible to change the sim card to another provider.
anything else I can try?

According to the results you provided to get the time by “AT+CCLK”, you have registered the network normally, but the time deviation is very large. there is also a possibility that it is caused by the addition of external circuits in the quectel’s module.

hi herbert,
the quectel module is used on a quectel evaluation board adapter, which is connected to a linux host via usb.
no additional hardware modifications are used.

I am very sorry that I failed to solve the problem you are currently facing. Do you have any other modules that can be used for cross-validation test?Or use the SIM cards of individual members of your company;If the problem still cannot be solved, we suggest you give a detailed description of the problem and send it to for help, or you can update the firmware version of the module to try to solve the problem.

hi herbert:
the problem exist also with another quectel module (ec21).
trying a different sim card is not an option, as the final solution has to work with currently used one.
ATI shows the following information:
Revision: EG25GGBR07A06M2G
is there available a newer firmware version?

You can download the latest firmware version from the link below,If your problem is still not resolved after the upgrade, I think it may be related to your mobile network.

hi herbert,
thank you for the firmware. can you please provide me some instructions of how to update the firmware?

Please download the upgrade tool from the link below:

hi herbert,
I downloaded the upgrade tool, but the contained documentation file is in chinese only.
I tried to load the contents.xml file, but then getting “error, tool can not detect platform name”.
Can you please give me some more detailed instructions of how to update the firmware.

Can you take a screenshot of your error? it may be a lack of configuration.