EG18-ea - AT+QTEMP doesn't return temperatures

Hi, i have a Mikrotik LHG 18 (LHGGM & EG18-EA).

Using AT+QTEMP i only get OK as output. It doesn’t return temperatures.

Firmware version is: EG18EAPAR01A12M4G

I expect this is one of the Quectel modems which returns the temperature readings in an unsolicited result code after the “OK” response.

Your software running the AT commands undoubtedly treats the “OK” response line as completion of the command response, when it’s not.

See this thread: EG-12EA bug: AT+QTEMP returns OK in wrong order

I already read the topic but i don’t think this is the same problem.
I get the same results using linux terminal, windows ssh, putty and the “web terminal” integrated in the modem.

Maybe the Mikrotik software (RouterOs) ?

What does AT+QINDCFG="all" return?




You are probably right.
Trying QPING there’s no output shown after the OK message.

Is there any way to have the behaviour of the QTEMP command fixed to print the OK at the end of the message?

Have you tried the Linux picocom or minicom command? They certainly show up any URCs.


+QINDCFG: “all”,1

setting should get you a URC result from AT+QTEMP following the “OK”.

Just a thought. You could try running just AT as an AT command a second or two after running AT+QTEMP to see whether that picks up the URC from the previous command and places it before its own “OK” response.

I did try iy but with no results

Anyway, i figured out a way to make it work:


You were right, and the “OK” answer before the actual answer is the problem.

Any way to ask them to fix this?

You could try. But that would leave two versions active in the field.

I’d like to know why they’ve implemented it this way.

1 Like