EC25E I can't connect to AWS iot

I’m using EC25E and I can’t connect to AWS iot server.
I think EC25E not connect by aws root certificate.
Could you connect to aws iot by EC25E?
EC25E F/W is EC25EFAR06A03M4G …

EC2x work fine with Amazon, Azure, Google… etc

Remove/skip root cert and test…
Write about result

I can’t find AT command for skip root CA.
Could you please let me know AT command?

Dont store/set root ca
Use only private cert and key

WoW~ I can connect to Google without root CA.
But I can’t connect to AWS iot…
I can see the TCP connection and FIN packet via wireshark between EC25E and AWS iot server.
EC25E as soon as connection send FIN packet.

so … your Private Certs & Key is wrong


Thank you so much~!
I’m using AT command on EC25E. I think I should be check the setting value about SSL configuration value…

Is it use the AT command in Arduino library?

in Arduino I use direct Linux API libraries … is the same as AT commands

Thanks Stephen Li … try / test this CA ROOT ( and check your private certificates )

tested with BG96 / 95, BC66, EC2x

I will try to test using that Root CA file.


I was upload the RootCA, clientcert and clientkey file into the RAM of EC25, and the I didn’t test well.
If I’m not use the Amazon Root CA, Should I modified the AT+QSSLCFG value or Amazon iot core setting ?

Someone said, Current EC25E & EC21KL doesn’t support AWS IoT because the policy of AWS root certificate has been changed since mid of last year.

Could you please try to test using EC25 for me ? now?

for this ask Quectel

I paste you link ( before your movie ) for other CA_ROOT
or dont use root, skip settings for root ca, this check only server authority…

Could you please try to test using EC25 for me ? now?
hard :slight_smile: home-office-covid, I not have module for test

I test ( over PC Simulator ) 3 CA_ROOT pem files and all is OK
simulator use OpenSSL ( windows )
module use OpenSLL ( Linux )

#define AWS_CA_1  CERT_PATH "AmazonRootCA1.pem"
#define AWS_CA_3  CERT_PATH "AmazonRootCA3.pem"
#define AWS_CA_SF CERT_PATH "sf-class2-root.pem"

Hello, following this thread.
I am trying to connect to AWS IoT Core via Quectel’s EC200U-CN. I tried to upload root ca, client certificate and private key to the module via AT Commands. (The certificates I uploaded are without the “BEGIN CERT” and “END CERT” texts).
But when I tried to open the MQTT Connection: AT+QMTOPEN
the result is: +QMTOPEN: 1,5, result: 5: network connection error.
Please share any update regarding this issue.