EC25 Ring Indication

Hi, am not getting ring indication on /dev/ttyUSB2 (through which I am using minicom), what needs to be done for this? Am able to receive call with ata

Present status
+QURCCFG: “urcport”,“usbat”
(tried with usbmodem and uart also)

+QCFG: “urc/ri/ring”,“auto”,120,1000,5000,“on”,1

+QINDCFG: “ring”,1

+QCFG: “risignaltype”,“respective”

Some additional info, this is a 4g only network with purely volte calling (jio)
at+clip=1 is accepted but when at+clip? is run it returns error
No urc ring or clip indication in terminal but at+clcc returns info about call and caller.
How to enable urc ring and clip messages (this is needed for a particular application)?

Also AT+CLCC displays foll even when there are no calls made to or from the module
+CLCC: 1,1,0,1,0,"",128
+CLCC: 2,1,0,1,0,"",128

Ok, this was solved through Quectel India FAE with debug logs sent to HO. Though AT+QINDCFG=“ring”, 1 was set, master switch for urc needs to be turned on with AT+QINDCFG=“all”, 1

Hi manojmat

I’m glad you have solved the problem. And I have sent to your email a document of the AT command,in which section 4.3 has a detailed introduction of URC.


Thanks Witt, the manual was very useful for me as I was looking for urc related to call status and AT^DSCI is exactly what I needed.