EC25 not receiving text messages after 30 minutes

I’m having an issue with my EC25 module. The sim card has hot swap enabled (AT+QSIMTAT=1,1). When the modem first boots up, it runs fine and receives text messages with no issues. After about 30 minutes, it doesn’t receive text messages unless I remove/reinsert the sim card. I’m not receiving any error messages. The device just hangs after 30 minutes. Sometimes, if I reboot the device it still won’t receive a texts until I physically remove the sim card and put it back in.

+CSQ: 23,99
+CNUM: ,"xxxxx",129
+COPS: 0,0,"T-Mobile",7

Hi @evo
Thank you for using quectel module, may I ask what firmware version you are currently using? You can use AT+QGMR queries. Also, after reinserting the SIM card, can you use AT+QENG=“SERVINGCELL” command to check the network status?

+QENG: "servingcell","NOCONN","LTE","FDD",310,260,1499302,37,2300,4,5,5,3F67,-115,-9,-79,11,8

Hi @evo
According to the returned information, the receiving level RSRP of the device has reached -115dBm, which indicates that the signal is very poor. Please confirm that the module antenna is properly installed.

Hi lyman-Q The antenna is pressed in completely on the board.

+CSQ: 16,99

When I run the signal command this is what I get. I’m going to run the +QENG command several times per second and see if changes.

+QENG: “servingcell”,“NOCONN”,“LTE”,“FDD”,310,260,1499302,37,2300,4,5,5,3F67,-114,-13,-81,11,9
+QENG: “servingcell”,“NOCONN”,“LTE”,“FDD”,310,260,1499308,37,675,2,4,4,3F67,-112,-12,-81,13,11

Thank you for your help.

I swapped out several antennas and the best I can get it to is between -110 and -112.

+QENG: “servingcell”,“NOCONN”,“LTE”,“FDD”,310,260,1499308,37,675,2,4,4,3F67,-112,-12,-82,12,11
+QENG: “servingcell”,“NOCONN”,“LTE”,“FDD”,310,260,1499308,37,675,2,4,4,3F67,-110,-17,-74,13,13
+QCSQ: “LTE”,79,-113,135,-13

So if the signal is poor, how is it possible that I’m able to receive sms messages once I reinsert the sim card? Right now, my solution is to reset the EC25 every 30 minutes.

Update #1
I left it to run overnight and the modem is still responding to me but not receiving SMS unless I reinsert the sim card. When I reinsert the sim card, the signal is still the same and I am able to receive all my SMS messages. The modem is unable to receive SMS messages after about 30 minutes to an hour. If I reboot my modem every 30 minutes by running AT+CFUN=1,1 the modem will receive messages.

Here’s what was shown when I reinserted the sim when leaving it running overnight,

+QENG: “servingcell”,“NOCONN”,“LTE”,“FDD”,310,260,1499308,37,675,2,4,4,3F67,-112,-12,-80,12,11
+CSQ: 20,99
+CNUM: ,“xxxxxx”,129
+COPS: 0,0,“T-Mobile”,7
+QENG: “servingcell”,“NOCONN”,“LTE”,“FDD”,310,260,2C7AA3F,245,68886,71,3,3,3F67,-110,-13,-79,13,-
+QCSQ: “LTE”,80,-115,93,-17
// Received a PDU message here but hidden
+CMTI: “SM”,23

Update #2
I ran this in QNavigator 1.5 on the evb breakout board. Same issue. About an hour later I can’t receive a message.