EC25 How can I lock LTE BAND using AT command

EC25
How can I lock LTE network BAND using AT command ?
to BAND40, BAND3
ie, TDD2300MHz and FDD1800MHz

1 Like

Make a note of the current setting first, using
AT+QCFG=“band”
to read this.

Then use the set syntax with bits 3 and 40 set in the LTE hex bandmask:

AT+QCFG=“band”,0,8000000004

If reapplying the original configuration later, omit the “0x” hex qualifiers in the output. They’re not part of the set syntax.

Thanks for your sharing. Thanks!

I am using a D Link 4G LTE router DWR M921 model having Quectel EC25E with firmware EC25EFAR06A08M4G.

Executed above command in AT command section and getting failed. Attached screenshot.

Kindly help

My error. When posting AT commands here we should use the Preformatted text feature. Otherwise those double quotation marks get converted to unicode equivalents. Hopefully, copy-and-paste works better with these double quotes as ASCII below:

AT+QCFG="band"
AT+QCFG="band",0,8000000004

Copy pasted. Still same

In those AT commands, band must be enclosed in ASCII double quotation marks (character 34 decimal). They are not showing in your screenshots.

Where are they? Have you tried entering the commands from the keyboard instead of pasting them?

I have the same chip. Here what I used hope it works for you too.
For band 3 use this line AT+QCFG=“band”,00,4,00
For band 40 use this line AT+QCFG=“band”,00,8000000000,00

You can not do LTE-A carrier aggregation with EC-25 series. This means you can only lock to single band 3 or band 40. If you want to get 2 bands signal you need to buy LTE-A EP06 chip that would support LTA Advance.

Unfortunately, the double quotes in your commands don’t render correctly in a copy-and-paste either. They paste as unicode characters, causing an “ERROR” response.

The reason for band-locking an EC25 to two bands is so that bands other than the chosen two get excluded, and not to attempt CA.

understood, thanks for your info

Still getting same error.
Is it due to firmware limit ?
My firmware is EC25EFAR06A08M4G

Dear Vaisagh,
For your issue, please make sure you use the right input method. Thanks!
AT+QCFG=“band” //check the current band setting
AT+QCFG=“band”,0, 8000000004,0 //lock to BAND3 and BAND40

Dear Team Support please help my modem return like this :

+QCFG: “band”,0x8d0,0x1a0880800d5,0x0

what is the band? my hardware EP06-E

Solution Anyone who has a similar problem.
AT+QCFG="band"

How can I lock into LTE band 1 ?

AT+QCFG="band",0,1