EC25-E Roaming Problems

Our device is used in a vehicle. It includes a Quectel EC25-E, to connect to a PPP access point (via Windows API).
This works fine in the home country, but not during roaming in Italy.
When we use the same SIM card with a different modem type, there are no problems with roaming.

But with the EC25-E, the situation is as follows:
AT+CGREG returns 0,5 (roaming).
AT+COPS? sometimes returns +COPS: 0,0,“WINDTRE”,2.
But in between, the response is often just +COPS:0.
So it seems that the modem restarts a provider search.

Rasdialin does not succeed. As soon as the vehicle is back in Austria, the home provider is found and connection works again.

The frequency bands enabled in EC25-E should be sufficient for provider WIND TRE. So I wonder what causes the modem to restart a provider search.

What can be wrong here, what can be done to fix the problem?

Hello KB_AFischer, thanks for your question
Regarding your response, if COPS returns 0, there is usually a problem with the network registration, so please confirm that the APN configured during roaming is correct, thank you.

Hello Duncan.Xu, thank you for your reply.
APN and credentials for RAS Dial are the same, no matter if in home network or in roaming.
So, while in Austria, the modem is successfully connected to the APN.
When crossing the border, the connection is lost.
For a short time, AT+CGREG returns a status of 3, AT+COPS returns 0.
Then AT+CGREG tells us we are roaming (5) and AT+COPS eventually reports the Italian provider WINDTRE.
All attempts for RAS Dial fail, with a Windows error code of 619.
Before RasDial, we check the configured APN via AT+CGDCONT, it is still the one we expect.

For troubleshooting, I now log the result of AT+CEER after Ras Dial failure, - here we got several numeric error codes: “5,27”, “3,11”
I also tried to provide the Ras Dial credentials (additionally) via AT+QICSGP (although the manual says it is not necessary). This did not solve the problem.

Even in the time between Ras Dial attempts, the response to AT+COPS toggles between 0 and WINDTRE.
CGREG remains at 5 (roaming).

The modem we use in older devices (Telit LTE modem LE920) works just fine under the same conditions and with the same SIM.

I would like to add more logging, before asking the customer for another test. Do you think that the result of AT+QENG=“servingcell” would give us a hint what is wrong? Or probably it would just return “SEARCHING”?
Are there other commands that provide helpful information?

Best regards, and thanks in advance!

According to the error code you provided, we found that the error code is an APN error
If you are very sure that your APN configuration is correct, please provide the problem log and send it to, and we will provide you with further assistance.
If you encounter other problems, it is recommended to refer to the attached standard module error code document, thank you.
Quectel_LTE_Standard_Error_Code_List_V1.0_Preliminary.pdf (742.0 KB)

Thank you for the information. I sent the logs to Quectel support.

Hello KB_AFischer,

I wonder if you have already solved this issue? I have met a similar issue with EG91. Do you mind tell me how do you handle it? Thank you.


Had the same problem on same modem, when travelling from Portugal to Spain and back.
Apparently modem does not register in network if valid APN for card is not set.
It is a portuguese operator card, and when entering Spain registration never occurs, so qmi (or ppp) never got a working data connection.
Solved it by always setting APN using AT+QICSGP command everytime modem starts.

Best regards,