EC25-E LTE CME Error 30

Hello, everybody,

we have installed the Quectel EC25-E on a Mini PC. This should establish an LTE connection. But every time I try to dial into the LTE network I always get the following error: +CME ERROR:30.

Ill try to check in with the following Command:

AT+COPS=1,0,“Vodafone.de”,7

Details about the modem:

Some Details:

**ATI**
Quectel
EC25
Revision: EC25EFAR06A04M4G

**AT+QCCID**
+QCCID: 89492025195207247737

**AT+CIMI**
262022507833259

**AT+CPIN?**
+CPIN: READY

**AT+QNWINFO**
+QNWINFO: "FDD LTE","26201","LTE BAND 8",3749

**AT+COPS?**
+COPS: 1

**AT+CSQ**
+CSQ: 13,99

**AT+CGREG?**
+CGREG: 0,0

**AT+CGDCONT?**
+CGDCONT: 1,"IP","m2mde.telefonica.com","0.0.0.0",0,0,0,0

**At+QCFG="nwscanmode"**
+QCFG: "nwscanmode",3

**AT+QCFG="usbnet"**
+QCFG: "usbnet",0

**AT+QENG="servingcell"**
+QENG: "servingcell","LIMSRV","LTE","FDD",262,01,1C54108,234,3749,8,2,2,34BE,-110,-11,-86,0,11

**AT+COPS=?**
+COPS: (1,"Vodafone.de","Vodafone","26202",7),(1,"Vodafone.de","Vodafone","26202",2),(1,"Vodafone.de","Vodafone","26202",0),(3,"E-Plus","E-Plus","26203",2),(3,"Telekom.de","TDG","26201",7),(3,"E-Plus","E-Plus","26203",0),(3,"Telekom.de","TDG","26201",0),(3,"Telekom.de","TDG","26201",2),,(0-4),(0-2)

Dear Mhlt,
Thanks for your inquiry in Quectel forum.
As you know that error code 30 means that no network service, so you can not establish a LTE connection.
image
Please check the following AT setting:
1).please change AT+COPS=0 (Automatic mode);
2).change AT+QCFG=“NWSCANMODE”,0,1
3)then reboot the module or AT+CFUN=0, then send AT+CFUN=1
image

Hi Kyson,

thank you for your fast reply.
I have set the follwing Options:

AT+COPS=0
AT+QCFG="NWSCANMODE",0,1

Then i reboot the Modem.

The Result from:
AT+COPS?
+COPS: 1,0,“Vodafone.de”,2

AT+QCFG="nwscanmode"
+QCFG: "nwscanmode",0

AT+QENG="servingcell"
+QENG: "servingcell","NOCONN","WCDMA",262,02,10D1,5E112A5,10564,331,2,-97,-5,-,-,-,-,-

AT+COPS=?
+COPS: (1,"Vodafone.de","Vodafone","26202",7),(2,"Vodafone.de","Vodafone","26202",2),(1,"Vodafone.de","Vodafone","26202",0),(3,"E-Plus","E-Plus","26203",0),(3,"E-Plus","E-Plus","26203",2),(3,"Telekom.de","TDG","26201",2),(3,"Telekom.de","TDG","26201",0),(3,"Telekom.de","TDG","26201",7),,(0-4),(0-2)

Why does the Modem want to use Access technology 2 instead of 7 ?

Dear MhlT,
Please make sure the SIM card can support LTE, and there have the LTE network signal in your test environment.
For module, you can check the following configuration:
AT+ACFG=“NWSCANSEQ” check whether the LTE is the top priority
AT+QCFG=“BAND” check whether the band configuration is correct
If the above configuration are correct, you can set AT+QCFG=“NWSCANMODE” to LTE to have a try. Thanks!

Hi,

i think that the settings fit so far:

AT+QCFG="NWSCANSEQ"
+QCFG: "nwscanseq",0403010205

AT+QCFG="BAND"
+QCFG: "band",0xd3,0x800135,0x0

I’ve set NWSCANMODE to LTE, but there’s been no change.
I have tested the same SIM card with a notebook without any problems. I have also tried other SIM cards with different providers.

Hi Maik,

please retry with AT+CGDCONT=1,“IPV4V6”,"" and power-cycling the device in case you still have the m2mde.telefonica.com APN there.

Regards,
Reinhard

Dear MhiT,
After you change the setting, have you try to reboot the mdoule or send AT+CFUN=0,AT+CFUN=1 to let the module research the network ?
By the way, if you lock the module to LTE mode, it is better to use AT+CEREG? to check whether the module can access the network normally. Thanks!

Hello together,

thank you all for the help.

The Soultion is to set AT+CGDCONT … now its work.