EC25-AU MBIM Support

Does the EC25-AU module support MBIM mode?

I have tried using AT+QCFG=“usbnet”,2 AT command to switch it to MBIM mode but the module doesn’t appear to change modes even after I power cycle it (ECM mode doesn’t work either).

I’ve seen some mentions around the place that SOME variants of the EC25 do NOT support MBIM mode but I’ve not found anywhere that says WHICH EC25 variants DO and DO NOT support MBIM mode.

The firmware on my EC25-AU device is EC25AUGCR06A01M1G.

Support have directed me to post my request here.

Answering myself because it appears support aren’t going to…

First off it turns out my module is actually an EC25-AUGC (the “GC” is hiding in tiny text under the EC25-AU etching on the RF can) which is the cost reduced version, I believe the difference is it’s only got 1GB of Flash and 128MB of RAM as opposed to the “full” AU version which has 4G of Flash and 256MB of RAM.

MBIM does not appear to be supported by firmware EC25AUGCR06A01M1G but after upgrading to EC25AUGCR06A03M1G it now works as expected.

A word of warning though, although if you issue an AT+QCFG=? it will tell you that valid values for “usbnet” are 0-4, it appears that 3 and 4 are either not implemented, or broken as when I tried these out of curiosity it broke my AT port and it was a bit of a challenge to get it back to a functional mode (there’s a very brief window at power up when the AT port will accept commands).

But after the firmware upgrade and running AT+QCFG=“usbnet”,2 the module now works fine in both my Windows 10 PC (you have to uninstall the qcwwan driver though because they’re broken, that will allow it to be picked up by the Generic USB Class driver, it will appear as “LTE Module” in Device Manager) and in my ROSv7.3.1 equipped Mikrotik RBM11G.

Thanks for your feedback, thank you! Quectel will always be at your service.