EC200U not connecting to internet on RPi

I have installed the quectel drivers as asked by Quectel.
These were the only files in the drivers provided under:

option.c option.mod.c qcserial.c qcserial.mod.c usb_wwan.c usb_wwan.mod usb_wwan.o
option.ko option.mod.o qcserial.ko qcserial.mod.o usb-wwan.h usb_wwan.mod.c
option.mod option.o qcserial.mod qcserial.o usb_wwan.ko usb_wwan.mod.o

The module is working and connecting with AT commands. I can see the USB0 through USB6 and can use it to get AT commands working, as well as GNSS.

I am using AT+qcfg=“usbnet”,3
My USB0 shows the IP address

This is my /dev folder:
autofs hidraw0 media1 ram12 sda tty14 tty31 tty49 tty9 vcs2 vcsu4
block hidraw1 mem ram13 sda1 tty15 tty32 tty5 ttyAMA0 vcs3 vcsu5
bsg hidraw2 mmcblk0 ram14 serial tty16 tty33 tty50 ttyprintk vcs4 vcsu6
btrfs-control hwrng mmcblk0boot0 ram15 serial1 tty17 tty34 tty51 ttyUSB0 vcs5 vcsu7
bus initctl mmcblk0boot1 ram2 sg0 tty18 tty35 tty52 ttyUSB1 vcs6 vga_arbiter
cachefiles input mmcblk0p1 ram3 shm tty19 tty36 tty53 ttyUSB2 vcs7 vhci
char kmsg mmcblk0p2 ram4 snd tty2 tty37 tty54 ttyUSB3 vcsa video10
console log mmcblk0rpmb ram5 spidev0.0 tty20 tty38 tty55 ttyUSB4 vcsa1 video11
cuse loop0 mqueue ram6 spidev0.1 tty21 tty39 tty56 ttyUSB5 vcsa2 video12
disk loop1 net ram7 stderr tty22 tty4 tty57 ttyUSB6 vcsa3 video13
dma_heap loop2 null ram8 stdin tty23 tty40 tty58 uhid vcsa4 video14
dri loop3 port ram9 stdout tty24 tty41 tty59 uinput vcsa5 video15
fb0 loop4 ppp random tty tty25 tty42 tty6 urandom vcsa6 video16
fd loop5 ptmx raw tty0 tty26 tty43 tty60 v4l vcsa7 video18
full loop6 pts rfkill tty1 tty27 tty44 tty61 vchiq vcsm-cma watchdog
fuse loop7 ram0 rpivid-h264mem tty10 tty28 tty45 tty62 vcio vcsu watchdog0
gpiochip0 loop-control ram1 rpivid-hevcmem tty11 tty29 tty46 tty63 vc-mem vcsu1 zero
gpiochip1 mapper ram10 rpivid-intcmem tty12 tty3 tty47 tty7 vcs vcsu2
gpiomem media0 ram11 rpivid-vp9mem tty13 tty30 tty48 tty8 vcs1 vcsu3

I can’t get to the internet or ping any URL or ip. It simply says host not reachable. The device seems to be on the network:

+CGCONTRDP: 1,5,“”,“”,“”,“”,“”
+CGCONTRDP: 1,5,“”,“”,“”,“”,“”

Please let me know if something is missing. Am I supposed to install any other driver? The documents seem to be old and ask for qmi_wwan or gobinet drivers.
I am using RPi 4 with 5.10.103-v7l+

Thank you for your help.

See Port forwarding on Quectel EG912Y-EU - #6 by jfrog
and a few previous posts.

Thank you for your reply jfrog. The AT+QCFG=“nat”,1 returns an error

Still not working.

It is not the key command, you can ignore this for now.
Make sure you set AT+qcfg="usbnet",1 and at+qnetdevctl=1,1,1
Also execute once AT+CGPIAF=1,1,1,0 for better IPv6 address formatting.

It worked with the following changes:


I am using AT+qcfg=“usbnet”,3. Should I be using 1 if it is working with 3?

The general rule is “RNDIS is for Windows, ECM - for Linux”, so I mentioned "usbnet",1 one more time intentionally.
To avoid extra NAT you need to use AT+QCFG="nat/cid",0
Since you have IPv6 you need to use at+qicsgp=1,3,"your APN"