EC200U module start problem

Dear All,
I using Quectel device for first time and need help to start with EC200U.The development kit is UMTS&LTE EVB_V2.2.As per document of Quectel I have RUN the application setup.bat as admin but the command prompts opens for 3-4 secs and shuts Down.There is no Installation of any Drivers.
I am running this application on windoes 10.Please suggest any other Development Enviroment which i can proceed my work.

Thank you,
Firoz shaikh

Dear @firoz_quec
The problem you are facing now is that the USB driver cannot be installed。Can you tell me some details ?
Thanks !

Dear Sir,
I have all drivers and sdk but none of drivers are installing on windows 10 pro.The following image contains the error in command prompt and it shuts down.Please let me know any more specific details required and please suggest how to run the SDK.Do SDK require any IDE or any other procedure.

Dear @firoz_quec
I’m sorry to reply you so late. After the driver is installed, connect the module to the host through USB.
1.If the module has never downloaded firmware before, the module will enter the download mode after the module’s booting, and the port can be viewed in the device manager of the host, as shown in Figure 1.image
2.If the module has downloaded the firmware, the ports can be viewed in the device manager of the
host after the module’s booting, as shown in Figure 2.image
In addition, the application compilation tool chain of EC200U quecopen module adopts gcc-arm-none-eabi, which is the GCC tool chain of arm bare metal system. The GCC arm none EABI tool chain is integrated in the quecopen SDK, which is located in prebuilds Directory, version 7.2.1.
(ps:I have a Chinese version of the SDK quick development guide, but unfortunately there is no English version. If you need it, I can send it to you through email)

1 Like

I have connected the development Board but the driver are not downloaded and below is device manager detecting in COMPORT 12.Also please send the user guide on the email firoj.shaikh@novirelpt_pic

My email ID is also send chinese document also,I will translate and manage to start the board.

Dear @firoz_quec
I’m very sorry to reply to you now. I’ve sent you the SDK quick development guide by email. Please check it.
Best wishes to you !

Dear Sir,
I am using the SDK on Microsoft visual studio 2019.When We are trying to build the code the SDK gives different build error most of the time and same SDK runs successfully sometimes without any change in the code.

Dear @firoz_quec
This compilation error may be caused by multithreading parallelism. You can do the following:

  1. Try to compile again to see if the compilation is successful;
  2. If the compilation fails, please modify the build under the SDK root directory_ The code snippet of build_all.bat file is as follows: (3 here indicates the number of threads that are compiled simultaneously by the compilation operation thread. This parameter mainly depends on how many threads the PC can support. You can modify the parameter to test the maximum number of threads supported.)

Hello, I am tried the same but showing same error

Hello ,
when try run SDK that time showing these kind error also.

Dear firoz_quec:
I’m sorry to reply you so late. The error shown in the figure above, I still suggest you follow the steps of rapid document development step by step. If an error is still reported, it is recommended to check the file or code according to the corresponding error information. If it still cannot be solved, please contact our local FAE.
thank you

sir can i know at last how do you fixed this error i too have the same thing . i to cant able to see the port how to fix it please help me sir

Hi Ryan, please give me driver so that PC can see Quectel USB Modem as your image. My PC can not see this modem eventhough EC200U are installed suscess.


Thank you so much !

Hai sir We developing OPEN CPU using EC200U We collect the Document and SDK form local FAE
1- we done GNU APP compilation output We done
2- Quectel USB driver installation we done
3- firmware upgrade we done
i attached the screenshot in below kindly check.

what we do in next how to use SDK in Visual studio code we struggle in this part and also i ask my supplier he is not giving proper support to us
kindly give support to us soon as possible
thank you

Serial port