EC200U flashing error

I’m very new to the EC200U eval board. These are the steps I followed:

  1. Boot into Windows
  2. Supply power to the EC200U eval board via the USB cable.
  3. Connect the USB-to-Serial cable (appears as COM5)
    4, Push the PWRKEY pin for a second and wait until the blue LED starts flashing.
  4. Start QFlash in admin mode, select the relevant *merge.pac
  5. Press the Start button on QFlash.

I get the following uninformative error message (screenshot). Please advise on what to do next.

After waiting for a while, the status info in QFlash changes to “[COM0]Download fail[Open port fail]!” which is very strange because I don’t even have a COM0 on my computer. All the available COM ports are shown in the device manager screenshot.

Exactly the same problem! What could be the reason?

I tried on a different computer, and it worked flawlessly. I borrowed an old laptop from the office for flashing, and gave up on trying to solve the problem on my main dev machine.