EC200T module signal quality

Good day,

I am running the CSQ command on the EC200T module with antenna connected. I get readings of between 25-31, 99 constantly - good enough signal.

I connect the module to my computer and run a speedtest after establishing an LTE connection. The speed test result is quite poor, about 20-30 times slower than what I get on my mobile phone.

I need to get more information on the LTE signal quality for me to optimize the antenna. I did some reading up and saw that the RSSI is not the only indicator to look at: RSRP, RSRQ and SINR are some parameters to consider. Indeed it is possible to have a good CSQ but a slow connection. Is there a way for me to get more/other values from the module to see how certain environments affect connectivity? I want to do this to optimize the antenna setup.





Hello Herbert,

Thank you for this. It helped me quite a bit.

So here’s the situation: I’m testing the EC200T module on the MINIPCIE-EVB_KIT and connecting to the internet on my Windows PC via the module. The +QENG command returns this:

+QENG: “servingcell”,“NOCONN”,“LTE”,“FDD”,204,08,A9C52A,176,500,1,5,5,FBF5,-91,-16,-73,17,34

I am getting poor download speed tests with this connection. I run a download speed test on my phone and get much higher speeds (as stated). This through LTE.

Note the antenna on the module is unmatched.

Do you have any advise on how to up the module download speed so that it can compare more with my phone’s LTE connection? Should I even expect that it compares? I figured USB comms speed should be fast enough to get above 3Mbps download speed…



As the downlink bandwidth of the base station cell connected to your device is 5M, your device download rate is relatively low,and the maximum peak rate, if achievable, is around 35Mbps.
Peak rate test recommendations:
1、Use USB3.0 as much as possible;
2、Download file packets large enough;
3、Download files through FTP;
4、The maximum number of downloaded processes was set,such as 10.

Hello Herbert,


Still, it would be desirable to achieve the max rate as determined by the base station. Can that value of 5M be forced to change?

The module is a USB2.00 module. I cannot achieve USB3 ? Besides, USB2 speeds in theory is 480Mbps so that should not be an issue?

Hello Herbert,

FYI I did try this: AT+QCFG=“band”,00000000,4

But the UL and DL values of 5 did not change as I expected it would


This download bandwidth is determined by the base station, and you can’t change it, only by the local operator.If your test rate is around 20Mbps, that’s normal.

Thanks Herbert,

My download test at is around 3Mbps.

Given all the information above, do you think this can be caused by the unmatched antenna?

The pi matching circuit has DNP components and a zero ohm resistor that directly connects the antenna to the pin of the modem.

Do you think the there could be other causes?


It’s not likely to be caused by an antenna.
There are no comparative tests, so we can’t do any screening.

Hi Herbert,

Please allow me to check something you said. According to the manual the 5,5 translates to 20MHz bandwidth upload and download. Surely that means faster speeds?



You can see LTE carrier bandwidth versus speed by looking it up on Google.

Frequency bands. Under certain conditions different frequency bands may also affect data transfer rates. Higher frequency bands can generally provide better speeds. However, lower frequency waves traverse the environment more effectively and may provide better speeds in areas with many possible signal obstructions (such as urban areas).

You’re using band B1. With the modem in all-bands mode, what does the AT command:



There may be alternative bands shown with good signal which will perform better.

Hi snowgum,

Thanks for your reply.
I run “servingcell” and “neighbourcell” :

+QENG: “servingcell”,“NOCONN”,“LTE”,“FDD”,204,08,A9C52A,176,500,1,5,5,FBF5,-90,-16,-72,16,35

+QENG: “neighbourcell inter”,“LTE”,1300,65535,-140,-20,-,-,0,12,12,6
+QENG: “neighbourcell inter”,“LTE”,3150,65535,-140,-20,-,-,0,20,16,4
+QENG: “neighbourcell inter”,“LTE”,38100,65535,-140,-20,-,-,0,20,16,4
+QENG: “neighbourcell inter”,“LTE”,6400,65535,-140,-20,-,-,0,2,26,3
+QENG: “neighbourcell inter”,“LTE”,10145,65535,-140,-20,-,-,0,20,16,0

Not sure but I think the neighbourcell indirectly returns that there’s no other options? No RSSI…


There’s no actual signal strength being reported, as you say. But you seem to have EARFCNs reported, and we can lookup the bands from those channel numbers.

500 B1, mask 1 (the serving cell)
1300 B3, mask 4
3150 B7, mask 40
38100 B38, mask 2000000000
6400 B20, mask 80000
10145 B32, mask 80000000

We don’t know if any of these bands has enough signal (or bandwidth) to be usable, but you could band-lock to each in turn to try. The command is AT+QCFG=“band”,0,{mask}

So eg AT+QCFG=“band”,0,80000 to try B20.

Hi snowgum,

I tried the other bands and the best I got was B20 with approximately 6Mbit/s download speed compared to 3Mbit/s in the other bands. Still slower than what I expected.

What is your opinion on the effect of an unmatched antenna? Did you notice the poor RSRQ as well?


I don’t have the experience with this aspect to comment, sorry.

Hello all,

I tested some new antennas and I still need some information, please - it’s getting quite frustrating to be honest

The latest result I have is this:
+QENG: “servingcell”,“NOCONN”,“LTE”,“FDD”,204,08,A9C50C,107,6400,20,3,3,FBF5,-76,-12,-65,12,49

All the parameters look fine, according to me, yet I still get incredibly poor download speeds when I run a standard online speed test. I’m using the MINIPCIE devkit and the EC200T module with the USB drivers installed on Windows. What am I missing? Is there speed reduction through USB/Serial? Is there some other setting on the module that requires attention? My maximum download speed on the LTE connection is around 5Mbps. Regardless of what has been discussed above, I still expect a higher download speed. No matter what I do (adding RX diversity antenna, testing new antennas, switching bands) the download speed seems “capped” at 5Mbps and always falls between 2-5 Mbps. I’m expecting at least more speed changes.

Please advise, it would be much appreciated. Thank you!


I’m also facing some issues with EC200T module. I’m using KuWfi router, and my LTE connection only works for just a matter of ten seconds. After doing Ookla Speedtest, it’s gone and saying check internet connection. I tested the same LTE sim card on pocket wifi router and it doesn’t have any issues there, and no dropping of LET connection. I just wonder if anyone experience the same?

You can use AT+QENG=“ServingCell” to check the network environment and it is best to check RF performance using CMW500.

+QENG: “servingcell”,“LIMSRV”,“LTE”,“FDD”,460,01,B0C0347,486,350,1,3,3,181D,-54,-7,-29,25,73

The thirteenth field(-54) is RSRP.