Ec200t AT port not detected

When the USB port of EC200T device is connected to a Linux PC ( running ubuntu) … we first see that a Marvell device with Vendor ID = 1286 and Product ID = 821A is detected ( output of lsusb command) … almost within few seconds it diappears and one of the two below things happen
a) Marvell device diappears and another device with Vendor ID= 2c7c and Product ID = 6026 appears ( again output of lsusb command is used to check USB connected devices)
b) Marvell device diappears and no other device appears in its place

When the case b) happens we can not proceed further since the Quectel EC200T device is not detected , hence we can not pass on AT command to module over USB port
can you help explain - why above may be happening ? We have already mass produced around 1800 EC200T based USB dongle - which worked well for us … but recently on about a 100 devices we are facing above issue.

Can you help resolve this ?


Further i am attaching the bootup logs for both Working and Non working boards.
Also note that after putting the EC200T in download mode we are able to download the EC200TCNHAR05A03M16 version of software … but still the non working boards do not come up (3.6 KB) (839 Bytes)

Try to upgrade the module in forced download mode.

Hello Issac, we have tried that and it did not work.
Actually now on hindsight we realise that the problem that has happened is that we have accidently programmed the modules that had R02 release firmware with R05 release firmware.
This was not supposed to be done. R02 could have been upgraded only to R03.

Now that we know this we have put these modules ( Earlier R02 upgraded to R05) in forced download mode and tried to program R02 firmware again on them using QFlash tool. Qflash tool does display a PASS messge at the end of programming but then the Module does not function correctly. Still their AT port does not get detected … can you suggest some way of recovering these modules ?