EC200AEUHA-N06-SNASA how to use

hi people, i need a clear path to use some lte module
i buy 4 lte module EC200AEUHA-N06-SNASA
i’ve tried only one module on my openwrt router (OpenWrt 19.07.7, r11306-c4a6851c72) and my debian laptop (Linux portatile 5.10.0-16-amd64 #1 SMP Debian 5.10.127-2 (2022-07-23) x86_64 GNU/Linux)

both see the module as usb device

Bus 001 Device 010: ID 2c7c:6005 Quectel Wireless Solutions Co., Ltd. Android

and both create a cdc device (here the log from the openwrt router)

Fri Aug  5 17:41:38 2022 kernel: [4439195.754750] usb 2-1: new high-speed USB device number 6 using xhci-hcd
Fri Aug  5 17:41:38 2022 kernel: [4439195.936827] cdc_ether 2-1:1.0 usb0: register 'cdc_ether' at usb-f10f0000.usb3-1, CDC Ethernet Device, 02:0c:29:a3:9b:6d

then i create a wan interface over the usb0 ethernet adapter and enable the dhcp protocol, as expected, i obtain an ip address

usb0      Link encap:Ethernet  HWaddr 02:0C:29:A3:9B:6D
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::c:29ff:fea3:9b6d/64 Scope:Link
          RX packets:7 errors:0 dropped:0 overruns:0 frame:0
          TX packets:37 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:832 (832.0 B)  TX bytes:3338 (3.2 KiB)

the default gateway was , and now i’m locked here and i can’t understand how to use the module

i expect to navigate with my browser to this address and found a web page where i can configure the apn i will use … but there is’nt a web page

root@OpenWrt:~# nmap -T5
Starting Nmap 7.70 ( ) at 2022-08-05 17:49 CEST
Warning: giving up on port because retransmission cap hit (2).
Nmap scan report for
Host is up (0.00020s latency).
Not shown: 999 closed ports
53/tcp filtered domain
MAC Address: 00:26:26:26:26:26 (Geophysical Survey Systems)

Nmap done: 1 IP address (1 host up) scanned in 13.35 seconds

here the usb -t output from my laptop

T:  Bus=02 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  6 Spd=480  MxCh= 0
D:  Ver= 2.00 Cls=ef(misc ) Sub=02 Prot=01 MxPS=64 #Cfgs=  1
P:  Vendor=2c7c ProdID=6005 Rev= 3.18
S:  Manufacturer=Android
S:  Product=Android
S:  SerialNumber=0000
C:* #Ifs= 5 Cfg#= 1 Atr=e0 MxPwr=500mA
A:  FirstIf#= 0 IfCount= 2 Cls=02(comm.) Sub=06 Prot=00
I:* If#= 0 Alt= 0 #EPs= 1 Cls=02(comm.) Sub=06 Prot=00 Driver=cdc_ether
E:  Ad=87(I) Atr=03(Int.) MxPS=  64 Ivl=4096ms
I:  If#= 1 Alt= 0 #EPs= 0 Cls=0a(data ) Sub=00 Prot=00 Driver=cdc_ether
I:* If#= 1 Alt= 1 #EPs= 2 Cls=0a(data ) Sub=00 Prot=00 Driver=cdc_ether
E:  Ad=83(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=0c(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
I:* If#= 2 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=00 Prot=00 Driver=(none)
E:  Ad=82(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=0b(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
I:* If#= 3 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=00 Prot=00 Driver=(none)
E:  Ad=89(I) Atr=03(Int.) MxPS=  64 Ivl=4096ms
E:  Ad=86(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=0f(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
I:* If#= 4 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=00 Prot=00 Driver=(none)
E:  Ad=88(I) Atr=03(Int.) MxPS=  64 Ivl=4096ms
E:  Ad=81(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=0a(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms

what i’m missing???

today i notice that in my laptop when i inserted the module, it have a different vid:pid

343.030957] usb 1-1: new high-speed USB device number 12 using xhci_hcd
[  343.184458] usb 1-1: New USB device found, idVendor=2ecc, idProduct=3001, bcdDevice= 0.00
[  343.184468] usb 1-1: New USB device strings: Mfr=3, Product=2, SerialNumber=0
[  343.184472] usb 1-1: Product: WUKONG
[  343.184476] usb 1-1: Manufacturer: MARVELL
[  343.642826] usb 1-1: USB disconnect, device number 12
[  351.410950] usb 1-1: new high-speed USB device number 13 using xhci_hcd
[  351.559882] usb 1-1: New USB device found, idVendor=2c7c, idProduct=6005, bcdDevice= 3.18
[  351.559890] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  351.559894] usb 1-1: Product: Android
[  351.559898] usb 1-1: Manufacturer: Android
[  351.559901] usb 1-1: SerialNumber: 0000
[  351.567054] cdc_ether 1-1:1.0 usb0: register 'cdc_ether' at usb-0000:00:14.0-1, CDC Ethernet Device, 02:0c:29:a3:9b:6d
[  351.609844] cdc_ether 1-1:1.0 enx020c29a39b6d: renamed from usb0

but i can’t find nothing on internet searching for 2ecc:3001

I will send a driver to you via email, you need to install it, and you may be upgrade your firmware.

ok, thanks, now i’ve complied the driver, and now when i plug in the modem i have 3 /dev/ttyUSB device
how now i can upgrade the firmware? where i can find it?

I have same issue with EC200A the openers detect the modem with cdc-ethernet and log same with yours.
could you share me some experience how to update the linux kernel driver to make it use QMI mode with /dev/cdc-wdm0 and ttyUSBx ?


ask isaac to share the source code with you, this is only for some kernel, i’ve tried to compile it on my debian and the system recognize the /dev/ttyUSBx device without problem.
i havent’ tried to make a connection because i need it onto the openwrt firmware and i’m trying slowly to port on it

Thanks your feedback a lot. one more last question, you still work under CDC-Ethernet ECM mode NOT QMI right? As I check EC200X series modem do not support QMI. do you know that?


finally i manage to compile the option.c under openwrt, and appear 3 ttyUSBx device, the ttyUSB1 and ttyUSB2 accept at command, and i can use one of this for ppp call like a regular modem, than i use it in this manner
i make a test with a gsm only sim, i obtain an iip address and i can ping google (with a very huge time … due to edge congestion)

if someone wants more info on openwrt compile, here my mail to the mailing list