EC200A download tool for Linux

I have an eval board for EC200A. Now I would like to flash the device from my Linux desktop. I do not have Windows, and do all my development from Linux.
has any solution under Linux to upload firmware?

As I know exist QFirehose tool for it but firmware for QFlash does not applicable for it (archive should has “recover/firehose” folder).
manual for QFirehose - How to upgrade module thru Linux QFirehose - #8 by venkatms
thread about retriving firmware in QFlash format - EC200A-EU latest firmware - #6 by herbert.pan-Q

1 Like

I have sent it to your email,pls check

I`m interesting too.
mohammad_mazarei, could you share your solution, if have?

thank you for your replay, but It’s not work for me, I think firehose protocol for Qualcomm SOC, but I use ASR version of EC200A,
my modem partnumber is EC200A-EUAB

pls try QDloader_Linux_Android_V1.0.11,I have sent it to you

1 Like

thank you, when try to use that I got error:

[000:000] Version: QDloader_Linux_Android_V1.0.11
[000:000] mcu is little endian
[000:000] scan quectel modem
/sys/bus/usb/devices/2-3 2ecc/3002/0
open(/dev/bus/usb/002/050) = 4
Segmentation fault

I use debian 12, modem is in boot loader and system detected that:

Bus 002 Device 050: ID 2ecc:3002 ASR Microelectronics FALCON

and I ran QDloader with this parameter

QDloader -f EC200AEUABR02A02M2G_OCPU/update/quectel_skylark_pm802_standard_AB_2G.blf

Hi, could you send QDloader too?

you can download from this post

1 Like

I have sent it to you

@herbert.pan-Q how can use QDloader tools ?

I have sent it to you

You need the FBFMake to generate the image for upgrade.
FBFMake.exe -r Falcon_EVB_QSPI_Nor_LWG_Only_Nontrusted_PM802_LPDDR2.blf -f out
Then the Binfile.bin will be in the out directory.

Could you send me FBFMake.exe too?

Sent already
Please check your email

1 Like

Hi all,
Do you have FOTA server with EC200 firmware Updates?
This is cool feature -

Hi, Could you send me FBFMake.exe?

I will send it via email.
It is Windows format tool

maybe can I run with wine on Linux