EC20 module on openwrt, port forwarding fails, problem consultation

Hello friend
I’m currently using an EC20CEHCLG and an x86-64 openwrt system. The ECM pattern recognition device is usb0. The routing results displayed on the network are as follows:
WAN 0 Primary
LAN 0 master 0 Main
Of course, the EC20 module is connected to the qmi_wwan0 network, but the port is still restricted and cannot be accessed from the outside.
The operator here uses a dynamic public IP, which is refreshed every 24 hours. The network type I used to test is NAT1. Currently I am on the network segment 192.168.43.*. For example, port 3000 cannot be accessed from the external public network. I discovered that the modem has a LAN of and I cannot use the UPnP or DZM functionality of the modem itself. Does the LTE module itself have this port forwarding functionality? The UPnP function of openwrt is turned on, so how to use the port forwarding function of EC20 itself? (The previous statement was not clear enough and has been modified)
Looking forward to your reply, thank you

Switch the modem to QMI or MBIM, then ask a question at OpenWrt forum.

Hello, maybe I didn’t express myself clearly enough. I just want to know: is there a way to forward the port inside the modem? Because I tried UPnP in openwrt, but found that there was another LAN on the upper layer, which prevented me from opening my own port.

AFAIK, there is no user-friendly way to configure IP passthrough or port forwarding on this model, so the recommendation is to switch from ECM mode and the question will lose its relevance.

thank you for your reply. I tried it in ECM mode, but there is no solution for now.

The solution is to change from ECM to MBIM or QMI and thereby stop using the modem as a NAT router.

It has been switched, the system displays wwan0, and the network has been connected using qmi_wwan0, but how to stop using the modem as a NAT router?

Last time: stop using it in ECM mode. In other modes it behaves like a network card, not a router.

So I would like to ask you, how to operate the AT command? Thanks

Please refer to this page.

OK, thank you for your reply