EC20 can't detect sim card after restart the PC

Hi team

First, when I receive the PC. It was able to detect the sim card.

The wireless adapter chip is EC20.

After the PC is restarted, the windows always show INSERT SIM, go through troubleshooting it said “There is no SIM in the mobile broadband device”.

After the tried update the driver, reinstall the driver, update the windows all of these still cause the same problem.

Any idea to solve the problem.

Thanks

Dear Wilson Jong,
Thanks for your inquiry in Quectel forum.
Could you help to check it can restore if you restart the module to have a try ? If it is hard to restart the module, how about to send AT command to check the module status ? You can send AT+CPIN? to check the SIM card is OK via USB AT port. And you also can check the SIM card connection is normal or not. Please help to provide more information, then we can help you to fix the issue. Thanks!

Thank you for reply.

I have tried to reset the PC but it still have the same problem.

Could you explain to me how to check the AT+PIN and how to run the AT command?

I tried to install sim card to my phone and the connection is fine.

Thanks.

Dear Wilson Jong,
Please click the following link to download the test tool, and use this tool to send AT command.
https://cnquectel-my.sharepoint.com/:u:/g/personal/asean-fae_quectel_com/ETKHg6c1CAtFgLFJd47xyFwB_BWKGqCmaB2aBUWmJNxFJA?e=TA16eI

Please check the following method to send the command. Thanks!

Dear Kyson,

I have restart the PC then it able connect to the cellular network.

Then when I restart the PC again, it cause the same problem.

This image is the when the pc is not able to connect to the cellular network.

Thanks for helping.

Dear Wilson Jong,
Error code 13 means that SIM failure, which means that there may have the interference on SIM card circuit. So it is better to confirm it. You also can try to send AT+CFUN=0, then send AT+CFUN=1 to check whether it can restore. If still have the error information, please check the SIM card circuit design. Thanks!
image

Dear Kyson,

The solution you provided to me is working.

But I have another PC have the same problem, but when I used the same method tried to solve the problem, then it not working.

It always say sim card not inserted even the sim card had installed in it. I have tested the sim card, the sim card is fine.

Thanks you for helping.

Dear Wilson Jong,
If the method i provide to you still not working, it is better to check whether the SIM card connection is OK, you can unplug then plug the SIM card. If still have the issue, it is better to check the SIM card circuit of your board. Thanks!

I mentioned this problem in another thread. You said that problem is about that. I think so too.

Blockquote

which means that there may have the interference on SIM card circuit

Blockquote